summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibrewish2019-10-28 11:57:37 +0530
committerlibrewish2019-10-28 11:57:37 +0530
commit75e1b0ab624025039c34b1d5a2f24a52c11f3f92 (patch)
treed35bbab66cedb2152ac42c926245a4e072dd89d7
downloadaur-75e1b0ab624025039c34b1d5a2f24a52c11f3f92.tar.gz
init
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..455300e8ee08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = wf-osk-git
+ pkgdesc = A very, very basic on-screen keyboard for wayland using gtkmm, virtual-keyboard-v1 and layer-shell protocols
+ pkgver = r7.d28bd69
+ pkgrel = 1
+ url = https://github.com/WayfireWM/wf-osk
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ makedepends = wayland-protocols
+ makedepends = extra-cmake-modules
+ depends = wayland-protocols
+ depends = gtkmm3
+ depends = gtk-layer-shell
+ provides = wf-osk-git
+ provides = wf-osk
+ conflicts = wf-osk
+ source = git+https://github.com/WayfireWM/wf-osk
+ sha256sums = SKIP
+
+pkgname = wf-osk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9630fa56987a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=wf-osk-git
+pkgver=r7.d28bd69
+pkgrel=1
+pkgdesc="A very, very basic on-screen keyboard for wayland using gtkmm, virtual-keyboard-v1 and layer-shell protocols"
+arch=('any')
+url="https://github.com/WayfireWM/wf-osk"
+license=('MIT')
+depends=('wayland-protocols' 'gtkmm3' 'gtk-layer-shell')
+makedepends=('git' 'meson' 'ninja' 'wayland-protocols' 'extra-cmake-modules')
+provides=("${pkgname}" "wf-osk")
+conflicts=("wf-osk")
+replaces=()
+options=()
+source=('git+https://github.com/WayfireWM/wf-osk')
+sha256sums=('SKIP')
+prepare() {
+ cd "$srcdir/wf-osk"
+ git submodule update --init --recursive
+}
+pkgver() {
+ cd "$srcdir/wf-osk"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+build() {
+ cd "$srcdir/wf-osk/"
+ rm -rf build
+ arch-meson build
+ ninja -C build
+}
+
+
+package() {
+ cd "$srcdir/wf-osk"
+ DESTDIR="$pkgdir/" ninja -C build install
+}