summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandar Trifunovic2020-04-29 13:34:08 +0200
committerAleksandar Trifunovic2020-04-29 13:34:08 +0200
commit761400f368e71b1390a53f3eccd1eee8067268bf (patch)
tree3f0c8c2a05b7fc79c744f4b4703427ab88e0aeca
parentf76175aac1db5d2b44125289456663024a3bf463 (diff)
downloadaur-761400f368e71b1390a53f3eccd1eee8067268bf.tar.gz
v2.3.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 503f24e73ec8..d532ed59cfcc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lightgbm
pkgdesc = Distributed gradient boosting framework based on decision tree algorithms.
- pkgver = 2.3.0
+ pkgver = 2.3.1
pkgrel = 1
url = https://github.com/Microsoft/LightGBM
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = lightgbm
depends = boost-libs
depends = ocl-icd
depends = openmpi
- source = https://github.com/Microsoft/LightGBM/archive/v2.3.0.tar.gz
- sha256sums = e076034ef41229714d59f28c3bd2366830dd9dfb9deff62f9ebc6a26f9e1e975
+ source = https://github.com/Microsoft/LightGBM/archive/v2.3.1.tar.gz
+ sha256sums = b2b8ed5e06be21444c4e9defd66877510d1800a650543f75bfc1b28f77745b84
pkgname = lightgbm
diff --git a/PKGBUILD b/PKGBUILD
index 76de08bf490d..ae9e1a437535 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=LightGBM
pkgbase=lightgbm
pkgname=("${pkgbase}" "python-${pkgbase}")
-pkgver=2.3.0
+pkgver=2.3.1
pkgrel=1
pkgdesc="Distributed gradient boosting framework based on decision tree algorithms."
arch=('x86_64')
@@ -12,7 +12,7 @@ license=('MIT')
depends=('boost-libs' 'ocl-icd' 'openmpi')
makedepends=('boost' 'cmake' 'opencl-headers' 'python-setuptools')
source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('e076034ef41229714d59f28c3bd2366830dd9dfb9deff62f9ebc6a26f9e1e975')
+sha256sums=('b2b8ed5e06be21444c4e9defd66877510d1800a650543f75bfc1b28f77745b84')
build() {
cd "${_pkgname}-${pkgver}"
@@ -44,5 +44,4 @@ package_python-lightgbm() {
sed -i 's/..\/..\/lib\//\/usr\/lib\//' lightgbm/libpath.py
python setup.py install --root="$pkgdir/" --optimize=1 --gpu --mpi --precompile
install -Dm644 ../LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
- rm "$pkgdir/usr/lib/python3.7/site-packages/lightgbm/lib_lightgbm.so"
}