summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-07-15 14:53:18 +0800
committerUniversebenzene2020-07-15 14:53:18 +0800
commit7657ce4a837dbc567b90c979ddc616b79982bf03 (patch)
treefdf9ec18826f98d465afb3fd7dbc58541368a556
parent4274092d22442084beb63c4cd3cb1421752a93b4 (diff)
downloadaur-7657ce4a837dbc567b90c979ddc616b79982bf03.tar.gz
Update to version 4.12.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 435625e0d7bf..ad70d9b62da0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-sherpa
pkgdesc = Modeling and fitting package for scientific data analysis
- pkgver = 4.12.0
+ pkgver = 4.12.1
pkgrel = 1
url = http://cxc.cfa.harvard.edu/contrib/sherpa/
arch = i686
@@ -13,18 +13,18 @@ pkgbase = python-sherpa
makedepends = python-sphinx_rtd_theme
makedepends = python-sphinx-astropy
makedepends = graphviz
- source = https://files.pythonhosted.org/packages/source/s/sherpa/sherpa-4.12.0.tar.gz
+ source = https://files.pythonhosted.org/packages/source/s/sherpa/sherpa-4.12.1.tar.gz
source = sherpa_local_fftw.patch
- md5sums = 53ff4f88c63cf7da5cf7dd44315aa627
+ md5sums = 2e886f781d7371ddf105cd4f14caa673
md5sums = d1823cc7683442d92450fadff7aed362
pkgname = python-sherpa
install = python-sherpa.install
depends = python>=3.5
- depends = python-numpy
+ depends = python-numpy>=1.7.0
depends = fftw
optdepends = python-matplotlib: Graphical output
- optdepends = python-astropy: Data I/O support
+ optdepends = python-astropy>=3.2.1: Data I/O support
optdepends = ds9: Imaging requires
optdepends = xpa: Imaging requires
optdepends = python-pytest>=3.3: For testing suite
diff --git a/PKGBUILD b/PKGBUILD
index 74cdb3553fb6..1ee71d8eaf6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=python-sherpa
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=4.12.0
+pkgver=4.12.1
pkgrel=1
pkgdesc="Modeling and fitting package for scientific data analysis"
arch=('i686' 'x86_64')
@@ -12,7 +12,7 @@ makedepends=('python>=3.5' 'python-numpy' 'fftw' 'python-setuptools' 'python-sph
#'gcc-fortran')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
'sherpa_local_fftw.patch')
-md5sums=('53ff4f88c63cf7da5cf7dd44315aa627'
+md5sums=('2e886f781d7371ddf105cd4f14caa673'
'd1823cc7683442d92450fadff7aed362')
_pyver=$(python -V | cut -c 8-10)
@@ -32,9 +32,9 @@ build() {
}
package_python-sherpa() {
- depends=('python>=3.5' 'python-numpy' 'fftw')
+ depends=('python>=3.5' 'python-numpy>=1.7.0' 'fftw')
optdepends=('python-matplotlib: Graphical output'
- 'python-astropy: Data I/O support'
+ 'python-astropy>=3.2.1: Data I/O support'
'ds9: Imaging requires'
'xpa: Imaging requires'
'python-pytest>=3.3: For testing suite'