summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2022-09-25 19:58:57 -0400
committerAndrew Sun2022-09-25 19:58:57 -0400
commit766da7e973fa7ea2f4cab8cf852c9c6d0eabb499 (patch)
tree09d7008b2d05664f91a0a1c4a8ce94ac0950b033
parentef3eac42a26dcfdfc1ebb37a0d1d2ff2d1960d84 (diff)
downloadaur-766da7e973fa7ea2f4cab8cf852c9c6d0eabb499.tar.gz
0.27.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 161d98a0e6a2..420a327b8ea7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = python-lifelines
pkgdesc = Survival analysis in Python
- pkgver = 0.27.2
+ pkgver = 0.27.3
pkgrel = 1
url = https://github.com/CamDavidsonPilon/lifelines
arch = any
license = MIT
makedepends = python-setuptools
+ depends = ipython
depends = python-autograd-gamma
depends = python-matplotlib
depends = python-pandas
+ depends = python-scikit-learn
depends = python-formulaic
options = !emptydirs
- source = lifelines-0.27.2.tar.gz::https://github.com/CamDavidsonPilon/lifelines/archive/refs/tags/v0.27.2.tar.gz
- sha256sums = 25c132dffe2700ef71834a88522d5c0bec399b769a59a1a4c8c46fde147ab31d
+ source = lifelines-0.27.3.tar.gz::https://github.com/CamDavidsonPilon/lifelines/archive/refs/tags/v0.27.3.tar.gz
+ sha256sums = 35f7c1431823293ba7421c6379c792da2071e2a4a8dc85c26ef7fc3695b294ed
pkgname = python-lifelines
diff --git a/PKGBUILD b/PKGBUILD
index 6b8c41974ec1..c578a573cc01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
_pkgname=lifelines
pkgname=python-lifelines
-pkgver=0.27.2
+pkgver=0.27.3
pkgrel=1
pkgdesc="Survival analysis in Python"
url="https://github.com/CamDavidsonPilon/lifelines"
arch=('any')
license=('MIT')
-depends=('python-autograd-gamma' 'python-matplotlib' 'python-pandas' 'python-formulaic')
+depends=('ipython' 'python-autograd-gamma' 'python-matplotlib' 'python-pandas' 'python-scikit-learn' 'python-formulaic')
makedepends=('python-setuptools')
options=(!emptydirs)
source=("${_pkgname}-${pkgver}.tar.gz"::"https://github.com/CamDavidsonPilon/lifelines/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('25c132dffe2700ef71834a88522d5c0bec399b769a59a1a4c8c46fde147ab31d')
+sha256sums=('35f7c1431823293ba7421c6379c792da2071e2a4a8dc85c26ef7fc3695b294ed')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"