summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-05 18:03:12 +0100
committerBartłomiej Piotrowski2018-01-05 18:03:12 +0100
commit76b2c683645ffd0ef652cb678c17d01a6e8ac6e4 (patch)
tree26facadc853e99514d7c29a910fafb5f92c488bc
downloadaur-76b2c683645ffd0ef652cb678c17d01a6e8ac6e4.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..495910117037
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = tcllib
+ pkgdesc = Set of pure-Tcl extensions.
+ pkgver = 1.18
+ pkgrel = 1
+ url = http://core.tcl.tk/tcllib/
+ arch = any
+ license = bsd
+ depends = tcl
+ source = https://github.com/tcltk/tcllib/archive/tcllib_1_18.tar.gz
+ md5sums = 08dac86021c30c0a85c0a159f085143c
+
+pkgname = tcllib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27b16694d3d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 194152 2016-10-31 13:48:24Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: dtw <dibble.at.thewrecker.dot.net>
+# Contributor: Mathieu Gauthier <mathgl@freesurf.fr>
+# Upgrade to ver. 1.8 - Pawel Bogur <jid:smeagol@uaznia.net>
+
+pkgname=tcllib
+pkgver=1.18
+pkgrel=1
+pkgdesc="Set of pure-Tcl extensions."
+arch=('any')
+url="http://core.tcl.tk/tcllib/"
+license=('bsd')
+depends=('tcl')
+#source=(http://downloads.sourceforge.net/sourceforge/tcllib/tcllib-${pkgver}.tar.gz)
+source=(https://github.com/tcltk/tcllib/archive/tcllib_${pkgver/./_}.tar.gz)
+md5sums=('08dac86021c30c0a85c0a159f085143c')
+
+package(){
+ cd "$srcdir"/tcllib-tcllib_${pkgver/./_}
+ tclsh installer.tcl -pkg-path "$pkgdir"/usr/lib/tcllib \
+ -app-path "$pkgdir"/usr/bin \
+ -nroff-path "$pkgdir"/usr/share/man/mann \
+ -no-examples -no-html \
+ -no-wait -no-gui
+ mkdir -p "$pkgdir"/usr/share/licenses/${pkgname}/
+ cp license.terms "$pkgdir"/usr/share/licenses/${pkgname}/COPYING
+ rm -f "$pkgdir"/usr/share/man/mann/{try,string,variable,zlib,coroutine}.n
+}