summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxwell Pray2018-03-31 02:24:23 -0700
committerMaxwell Pray2018-03-31 02:24:23 -0700
commit76b8650bc398e544667b7d94fd2979f3f4092dd9 (patch)
treeb364e36fc858eeca00b88f0eae8a89e410b7a2fd
parentba17dacf59f2e23d55db24ee14e078fb10a56b7f (diff)
downloadaur-76b8650bc398e544667b7d94fd2979f3f4092dd9.tar.gz
Use synthead's support-options-from-cli-and-config-file branch.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
2 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 795634815bd7..6e3d87507f19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = zmeventserver-git
pkgdesc = A WSS (Secure Web Sockets) based event notification server that broadcasts new events to any authenticated listeners.
- pkgver = 20171227.b6a8eca
+ pkgver = 20180331.f6e6a78
pkgrel = 1
- url = https://github.com/pliablepixels/zmeventserver
+ url = https://github.com/synthead/zmeventserver/tree/support-options-from-cli-and-config-file
arch = any
license = GPL3
makedepends = git
@@ -11,10 +11,12 @@ pkgbase = zmeventserver-git
depends = perl-json
depends = perl-lwp-protocol-https
depends = perl-net-websocket-server
- source = git+https://github.com/pliablepixels/zmeventserver.git
+ depends = perl-config-inifiles
+ backup = etc/zmeventnotification.ini
+ source = git+https://github.com/synthead/zmeventserver.git#branch=support-options-from-cli-and-config-file
source = zmeventserver.service
sha256sums = SKIP
- sha256sums = 8122983b57e7a7ea86311d832d5c4e613ed470ebfb5ba302b5b267c30a48ddbc
+ sha256sums = 24a523f42e0022792db99acdfb27c44f9951e25cd7ddcd92b82abbf60fe4d623
pkgname = zmeventserver-git
diff --git a/PKGBUILD b/PKGBUILD
index b8406fe9e11b..142357f85e37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
pkgname=zmeventserver-git
_pkgname=${pkgname%%-git}
-pkgver=20171227.b6a8eca
+pkgver=20180331.f6e6a78
pkgrel=1
pkgdesc='A WSS (Secure Web Sockets) based event notification server that broadcasts new events to any authenticated listeners.'
arch=(any)
-url='https://github.com/pliablepixels/zmeventserver'
+url='https://github.com/synthead/zmeventserver/tree/support-options-from-cli-and-config-file'
license=(GPL3)
depends=(
perl-crypt-mysql
@@ -14,16 +14,18 @@ depends=(
perl-json
perl-lwp-protocol-https
perl-net-websocket-server
+ perl-config-inifiles
)
makedepends=(git)
source=(
- git+https://github.com/pliablepixels/zmeventserver.git
+ 'git+https://github.com/synthead/zmeventserver.git#branch=support-options-from-cli-and-config-file'
zmeventserver.service
)
sha256sums=(
SKIP
- 8122983b57e7a7ea86311d832d5c4e613ed470ebfb5ba302b5b267c30a48ddbc
+ 24a523f42e0022792db99acdfb27c44f9951e25cd7ddcd92b82abbf60fe4d623
)
+backup=('etc/zmeventnotification.ini')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -31,15 +33,17 @@ pkgver() {
}
package() {
+ install -dm 700 -o 33 "$pkgdir/var/lib/zmeventnotification"
+
install -Dm 755 \
"$srcdir/zmeventserver/zmeventnotification.pl" \
"$pkgdir/usr/bin/zmeventnotification.pl"
+
+ install -Dm 644 \
+ "$srcdir/zmeventserver/zmeventnotification.ini" \
+ "$pkgdir/etc/zmeventnotification.ini"
+
install -Dm 644 \
"$srcdir/zmeventserver.service" \
"$pkgdir/usr/lib/systemd/system/zmeventserver.service"
-
- install -dm 770 -g http "$pkgdir/etc/webapps/zmeventserver"
- sed -i \
- 's,/etc/\(apache2/ssl\|private\),/etc/webapps/zmeventserver,' \
- "$pkgdir/usr/bin/zmeventnotification.pl"
}