summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2009-09-21 21:25:13 -0400
committerSlashbunny2009-09-21 21:25:13 -0400
commit76ce8f9a9380334661b3e5f6d40b048c138dfdb8 (patch)
tree9bcc70decac5bda0a6d8292fb143953f54e9f0e1
parent7a8333b560c415f75573026a95593ae40ed68b6d (diff)
downloadaur-76ce8f9a9380334661b3e5f6d40b048c138dfdb8.tar.gz
Added 64bit support to quake4
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19bf546f1c3c..43fad1a68da3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = quake4
pkgdesc = Quake 4 Engine. You need the retail .pk4 files to play.
pkgver = 1.4.2
- pkgrel = 2
+ pkgrel = 3
url = http://www.quake4game.com/
install = quake4.install
arch = i686
+ arch = x86_64
license = custom:"Quake 4"
license = custom:"PunkBuster"
depends = gcc-libs
diff --git a/PKGBUILD b/PKGBUILD
index ab7f94e1b995..16d6cabebafb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,19 @@
pkgname=quake4
pkgver=1.4.2
-pkgrel=2
+pkgrel=3
pkgdesc="Quake 4 Engine. You need the retail .pk4 files to play."
url="http://www.quake4game.com/"
license=('custom:"Quake 4"' \
'custom:"PunkBuster"')
-depends=('gcc-libs' 'libgl' 'sdl' 'zlib')
-arch=('i686')
+if [ "$CARCH" = "x86_64" ]; then
+ depends=('lib32-glibc' 'lib32-sdl' 'lib32-libx11' 'lib32-libxext' 'lib32-zlib')
+ optdepends=('lib32-nvidia-utils: Accelerated 3D with the NVIDIA binary blob video driver'
+ 'lib32-catalyst-utils: Accelerated 3D with the AMD/ATI binary blob video driver')
+else
+ depends=('gcc-libs' 'libgl' 'sdl' 'zlib')
+fi
+arch=('i686' 'x86_64')
install=quake4.install
source=('quake4.desktop' 'quake4.launcher' 'quake4-dedicated.launcher' 'quake4-smp.launcher' \
"http://www.1337-server.net/quake4/quake4-linux-${pkgver}.x86.run.gz")