summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Mielniczuk2019-05-28 21:52:06 +0200
committerMarcin Mielniczuk2019-05-28 21:52:06 +0200
commit76eba9e2cc1077fa448240aa858c5e70ace18484 (patch)
tree0b151e3fce4cb9b7ba81a7f28149155033fdbcdf
parent40375f6f5d5fadcc4496f209cd21c81322a3b903 (diff)
downloadaur-76eba9e2cc1077fa448240aa858c5e70ace18484.tar.gz
Workarond #2275
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d4d98a3d2fb..c0d9021cf427 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ampi-openmpi
pkgdesc = Adaptive Message Passing Interface, OpenMPI backend
pkgver = 6.9.0
- pkgrel = 1
+ pkgrel = 2
url = http://charm.cs.uiuc.edu/research/ampi/
arch = x86_64
license = custom:Charm++/Converse License
diff --git a/PKGBUILD b/PKGBUILD
index 9d519eb3f746..89aee1af9e53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_backend=openmpi
pkgname=ampi-${_backend}
pkgver=6.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Adaptive Message Passing Interface, OpenMPI backend"
arch=('x86_64')
license=('custom:Charm++/Converse License')
@@ -13,11 +13,17 @@ source=("http://charm.cs.illinois.edu/distrib/charm-${pkgver}.tar.gz")
sha512sums=('894d154b7d8a8757e76838d97b0fd969fd4fa874956c80af7ea0766687272bbbe7df342b7e5d77e460ea883185de8b0f8f9926548e6ef4b9b8ed00e3caef94d2')
build() {
- cd charm-${pkgver}
- ./build AMPI mpi-linux-x86_64 --with-production
+ cd charm-${pkgver}
+ ./build AMPI mpi-linux-x86_64 --with-production
}
package() {
- cd charm-$pkgver
- make -C tmp install DESTDIR="${pkgdir}/opt/ampi-${_backend}"
+ cd charm-$pkgver
+ make -C tmp install DESTDIR="${pkgdir}/opt/ampi-${_backend}"
+ # Workaround https://github.com/UIUC-PPL/charm/issues/2275
+ for wrapper in ampicc ampiCC ampicxx; do
+ f="${pkgdir}/opt/ampi-${_backend}/bin/$wrapper"
+ echo "Patching $f"
+ sed -i 's|charmarch=$(cat $CHARMBIN/../tmp/.gdir)|charmarch=mpi|g' "$f"
+ done
}