summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorahoyiski2022-03-28 23:15:20 -0300
committerahoyiski2022-03-28 23:15:20 -0300
commit76f46c218ca05922f67fb96e31541b1d0f779121 (patch)
treeeeba49ab62e7e77df0aa95bacc4ca6e78cbd8ef1
parent79b555d01df2664109129b2810a41cdebd98fcff (diff)
downloadaur-76f46c218ca05922f67fb96e31541b1d0f779121.tar.gz
Fix 4.
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD3
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb0a00121d0c..75957decb475 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -49,3 +49,37 @@ pkgbase = wayfire-firedecor-git
sha256sums = SKIP
pkgname = wayfire-firedecor-git
+pkgbase = wayfire-firedecor-git
+ pkgdesc = An advanced window decoration plugin for the wayfire window manager.
+ pkgver = 1.14.b4a4029
+ pkgrel = 1
+ url = https://github.com/AhoyISki/wayfire-firedecor
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ depends = wayfire-git
+ provides = wayfire-firedecor-git
+ provides = wayfire-firedecor
+ source = git+https://github.com/WayfireWM/wayfire
+ sha256sums = SKIP
+
+pkgname = wayfire-firedecor-git
+pkgbase = wayfire-firedecor-git
+ pkgdesc = An advanced window decoration plugin for the wayfire window manager.
+ pkgver = 1.14.b4a4029
+ pkgrel = 1
+ url = https://github.com/AhoyISki/wayfire-firedecor
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ depends = wayfire-git
+ provides = wayfire-firedecor-git
+ provides = wayfire-firedecor
+ source = git+https://github.com/WayfireWM/wayfire
+ sha256sums = SKIP
+
+pkgname = wayfire-firedecor-git
diff --git a/PKGBUILD b/PKGBUILD
index 3980248efdcd..9b33c8e27b74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,14 +13,17 @@ source=('git+https://github.com/WayfireWM/wayfire')
sha256sums=('SKIP')
pkgver() {
+ cd "$pkgname"
printf "1.%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
+ cd "$pkgname"
meson build
meson compile -C build
}
package() {
+ cd "$pkgname"
meson install -C build
}