summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel Revilla2020-02-11 05:31:30 +0100
committerMiguel Revilla2020-02-11 05:31:30 +0100
commit76fca3b15596c9bc174ed0c3b8dcfbee7412abf4 (patch)
treeaca870c9fce5c38f035e74c5b6835a07a7659993
parentbbe9fcb5f33f799aed975c28b4e27c74c27f3540 (diff)
downloadaur-76fca3b15596c9bc174ed0c3b8dcfbee7412abf4.tar.gz
Update to 2.5.0b17
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD41
2 files changed, 30 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4da129e4f18..6749ccda4ab9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
pkgbase = libodb-boost
pkgdesc = The ODB boost profile library
- pkgver = 2.4.0
+ pkgver = 2.5.0b17
pkgrel = 1
- url = http://www.codesynthesis.com/products/odb/
arch = i686
arch = x86_64
- license = GPL
- depends = libodb
+ license = GPL3
+ depends = build2
depends = boost-libs
options = !libtool
- source = http://www.codesynthesis.com/download/odb/2.4/libodb-boost-2.4.0.tar.bz2
- md5sums = 6b0127619cab3244ae838780db890b9d
pkgname = libodb-boost
diff --git a/PKGBUILD b/PKGBUILD
index c3098fcfcc74..b366e2cfa774 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,42 @@
-# Maintainer: Miguel Revilla <yo@miguelrevilla.com>
-# Contributor: Miguel Revilla <yo@miguelrevilla.com>
+# Maintainer: Miguel Revilla <yo at miguelrevilla dot com>
pkgname=libodb-boost
-pkgver=2.4.0
+pkgver=2.5.0b17
pkgrel=1
pkgdesc="The ODB boost profile library"
arch=('i686' 'x86_64')
-depends=('libodb' 'boost-libs')
-url="http://www.codesynthesis.com/products/odb/"
+depends=('build2' 'boost-libs')
options=('!libtool')
-license=('GPL')
-source=("http://www.codesynthesis.com/download/odb/2.4/libodb-boost-${pkgver}.tar.bz2")
-md5sums=('6b0127619cab3244ae838780db890b9d')
+license=('GPL3')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}"
+ mkdir -p "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr --libdir=/usr/lib/odb --with-pkgconfigdir=/usr/lib/pkgconfig --with-libodb=/usr/lib
- make ECHO=echo
+ GPPVER="$(g++ --version | grep 'g++ (GCC)' | sed 's/g++ (GCC) //')"
+
+ bpkg create -d gcc-${GPPVER} cc \
+ config.cxx=g++ \
+ config.cc.coptions=-O3 \
+ config.bin.lib=shared \
+ config.install.root=${pkgdir}/usr
+
+ cd gcc-${GPPVER}
+ bpkg add https://pkg.cppget.org/1/beta
+ bpkg fetch --trust-yes
+ bpkg build --trust-yes ${pkgname} ?sys:libodb
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make ECHO=echo DESTDIR="${pkgdir}" install
+ GPPVER="$(g++ --version | grep 'g++ (GCC)' | sed 's/g++ (GCC) //')"
+ cd "${srcdir}/${pkgname}-${pkgver}/gcc-${GPPVER}"
+
+ bpkg install ${pkgname}
+
+ for f in ${pkgdir}/usr/lib/pkgconfig/*.pc; do sed -i "s|${pkgdir}||" ${f}; done
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}/
+ mv ${pkgdir}/usr/share/doc/${pkgname}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/
}