summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit7721e46aecbd6af6194086b57b9dc46ca8e1ee2d (patch)
tree03d2d032f4d8f54b58c6b0bf06569caf63c0dd03
downloadaur-7721e46aecbd6af6194086b57b9dc46ca8e1ee2d.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO15
-rwxr-xr-xPKGBUILD24
-rw-r--r--srtm2osm.sh3
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5dc3e981cc19
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = srtm2osm
+ pkgdesc = Generates elevation contours (isohypses) of a selected terrain from Shuttle Radar Topography Mission (SRTM) digital elevation model (DEM)
+ pkgver = 1.11.25.0
+ pkgrel = 1
+ url = http://wiki.openstreetmap.org/wiki/Srtm2osm
+ arch = any
+ license = GPL
+ depends = mono
+ source = http://osm.michis-pla.net/code/Srtm2Osm-1.11.25.0.zip
+ source = srtm2osm.sh
+ sha256sums = 3c486c6ca3a369fbac2ccfe43735c135498afaec4d4c6b0fcb5379069bc3e650
+ sha256sums = 46b126b476a6b7624c4e4271a660dcede892cbcc6ea1e2a9c09eaf274cef0bb6
+
+pkgname = srtm2osm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..c6c7f6ff279f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Arnaud Durand-Favreau <biginoz at FREE point FR>
+
+pkgname=srtm2osm
+pkgver=1.11.25.0
+pkgrel=1
+pkgdesc="Generates elevation contours (isohypses) of a selected terrain from Shuttle Radar Topography Mission (SRTM) digital elevation model (DEM)"
+arch=('any')
+url="http://wiki.openstreetmap.org/wiki/Srtm2osm"
+license=('GPL')
+depends=('mono')
+source=(http://osm.michis-pla.net/code/Srtm2Osm-$pkgver.zip
+ srtm2osm.sh)
+sha256sums=('3c486c6ca3a369fbac2ccfe43735c135498afaec4d4c6b0fcb5379069bc3e650'
+ '46b126b476a6b7624c4e4271a660dcede892cbcc6ea1e2a9c09eaf274cef0bb6')
+
+package() {
+ cd ${srcdir}/Srtm2Osm
+
+ install -d ${pkgdir}/opt/srtm2osm
+ cp * ${pkgdir}/opt/srtm2osm
+
+ install -D -m755 ${srcdir}/srtm2osm.sh ${pkgdir}/usr/bin/srtm2osm
+}
diff --git a/srtm2osm.sh b/srtm2osm.sh
new file mode 100644
index 000000000000..6803d3935553
--- /dev/null
+++ b/srtm2osm.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /opt/srtm2osm
+mono Srtm2Osm.exe