summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2018-02-05 13:05:54 -0500
committerredfish2018-02-05 13:05:54 -0500
commit772317cc6b926a650f2a21b7e9ee43fdef59a933 (patch)
tree60bf1bbff53216616a6dccbe196035384a9f8754
parentb58dcadbdaa66be822fd5cc86d18d3d1b57eae35 (diff)
downloadaur-772317cc6b926a650f2a21b7e9ee43fdef59a933.tar.gz
enable Qt GUI package; install only for gostcoind
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
-rw-r--r--gostcoind.install (renamed from gostcoin.install)0
3 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab52d0e5caf9..59def059e740 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Mon Feb 5 17:23:35 UTC 2018
+# Mon Feb 5 18:05:12 UTC 2018
pkgbase = gostcoin-git
pkgdesc = Coin based on GOST R 34.10 and GOST R 34.11-2012 with I2P support
pkgver = v0.8.5.10
pkgrel = 1
url = http://gostcoin.i2p
- install = gostcoin.install
arch = i686
arch = x86_64
arch = armv7h
@@ -15,8 +14,8 @@ pkgbase = gostcoin-git
makedepends = cmake
depends = boost-libs
depends = openssl-1.0
+ depends = qt5-base
optdepends = i2pd: I2P network transport
- backup = etc/gostcoind.conf
source = gostcoin::git+https://github.com/GOSTSec/gostcoin
source = gostcoind.service
source = gostcoind.conf
@@ -25,6 +24,12 @@ pkgbase = gostcoin-git
md5sums = a2811c45f7bdbb9dc66775f6f897631e
pkgname = gostcoind-git
+ install = gostcoind.install
provides = gostcoind
conflicts = gostcoind
+ backup = etc/gostcoind.conf
+
+pkgname = gostcoin-qt-git
+ provides = gostcoin-qt
+ conflicts = gostcoin-qt
diff --git a/PKGBUILD b/PKGBUILD
index 09a4d2ce911d..61c92c79fffb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: redfish <redfish@galactica.pw>
-#_BUILD_QT_GUI=1 # comment out to unset
+_BUILD_QT_GUI=1 # comment out to unset
pkgbase=gostcoin-git
pkgname=('gostcoind-git')
@@ -27,8 +27,6 @@ optdepends=('i2pd: I2P network transport')
source=("${pkgbase%%-git}::git+https://github.com/GOSTSec/gostcoin"
"gostcoind.service"
"gostcoind.conf")
-backup=("etc/gostcoind.conf")
-install="${pkgbase%%-git}.install"
pkgver() {
@@ -51,6 +49,10 @@ package_gostcoind-git(){
provides=('gostcoind')
conflicts=('gostcoind')
+ install="${pkgname%%-git}.install"
+
+ backup=("etc/gostcoind.conf")
+
install -Dm755 $srcdir/${pkgbase%%-git}/src/gostcoind "$pkgdir/usr/bin/gostcoind"
install -Dm0644 $srcdir/gostcoind.service $pkgdir/usr/lib/systemd/system/gostcoind.service
install -Dm0644 $srcdir/gostcoind.conf $pkgdir/etc/gostcoind.conf
@@ -70,7 +72,7 @@ package_gostcoin-qt-git(){
make
- install -Dm755 $srcdir/${pkgbase%%-git}/src/qt/gostcoin-qt "$pkgdir/usr/bin/gostcoin-qt"
+ install -Dm755 $srcdir/${pkgbase%%-git}/gostcoin-qt "$pkgdir/usr/bin/gostcoin-qt"
}
md5sums=('SKIP'
diff --git a/gostcoin.install b/gostcoind.install
index bcea5684eefc..bcea5684eefc 100644
--- a/gostcoin.install
+++ b/gostcoind.install