summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2022-11-01 04:21:25 +0800
committerlilac2022-11-01 04:21:25 +0800
commit7743788e7b366f43c1d594acfd0d266e07256835 (patch)
tree47560660acb0f96434f12b6d9595f2705ace1702
parenta381c76c6c93a7811e2cb537cbdf512d2d6ba4a6 (diff)
downloadaur-7743788e7b366f43c1d594acfd0d266e07256835.tar.gz
[lilac] updated to 6673.eb0767cc8-2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
-rw-r--r--pdf-import.patch37
3 files changed, 26 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c161d75d647..c5df9178220e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dia-git
pkgdesc = A GTK+ based diagram creation program (GIT VERSION)
- pkgver = 6672.4cd048d43
- pkgrel = 3
+ pkgver = 6673.eb0767cc8
+ pkgrel = 2
url = http://live.gnome.org/Dia
arch = x86_64
license = GPL
@@ -10,7 +10,6 @@ pkgbase = dia-git
makedepends = meson
makedepends = intltool
makedepends = dblatex
- makedepends = python
makedepends = docbook-xsl
depends = poppler
depends = python
@@ -27,6 +26,6 @@ pkgbase = dia-git
source = git+https://gitlab.gnome.org/GNOME/dia.git
source = pdf-import.patch
md5sums = SKIP
- md5sums = 741e89bf69b002e7bf40f62631bb1e7b
+ md5sums = 8a8ab2cc59c85686b40ae232495cb449
pkgname = dia-git
diff --git a/PKGBUILD b/PKGBUILD
index f4f822803ce3..5f38d237e9d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,21 +5,21 @@
pkgname=dia-git
_pkgname=dia
-pkgver=6672.4cd048d43
-pkgrel=3
+pkgver=6673.eb0767cc8
+pkgrel=2
pkgdesc="A GTK+ based diagram creation program (GIT VERSION)"
arch=('x86_64')
license=('GPL')
url="http://live.gnome.org/Dia"
depends=('poppler' 'python' 'libxslt' 'gtk2' 'freetype2' 'python2' 'graphene')
-makedepends=('git' 'cmake' 'meson' 'intltool' 'dblatex' 'python' 'docbook-xsl')
+makedepends=('git' 'cmake' 'meson' 'intltool' 'dblatex' 'docbook-xsl')
optdepends=('python2')
provides=('dia')
conflicts=('dia')
options=('docs' '!emptydirs')
source=("git+https://gitlab.gnome.org/GNOME/dia.git" "pdf-import.patch")
md5sums=('SKIP'
- '741e89bf69b002e7bf40f62631bb1e7b')
+ '8a8ab2cc59c85686b40ae232495cb449')
pkgver() {
cd "${srcdir}/${_pkgname}"
diff --git a/pdf-import.patch b/pdf-import.patch
index 3793a53b0953..05d8ffe888ea 100644
--- a/pdf-import.patch
+++ b/pdf-import.patch
@@ -1,6 +1,6 @@
--- plug-ins/pdf/pdf-import.cpp 2022-05-25 17:35:28.000000000 +0200
+++ plug-ins/pdf/pdf-import.cpp 2022-09-27 20:25:47.183817900 +0200
-@@ -152,13 +152,12 @@
+@@ -152,13 +152,12 @@ public :
void
updateLineDash (GfxState *state)
{
@@ -20,7 +20,7 @@
if (dashLength == 0)
this->line_style = DIA_LINE_STYLE_SOLID;
else if (dashLength > 5)
-@@ -318,10 +317,10 @@
+@@ -318,10 +317,10 @@ public :
//FIXME: Dia is really unhappy about zero size fonts
if (!(state->getFontSize() > 0.0))
return;
@@ -34,18 +34,18 @@
++font_map_hits;
return;
}
-@@ -333,8 +332,8 @@
+@@ -333,8 +332,9 @@ public :
gchar *family = g_strdup (f->getFamily() ? f->getFamily()->c_str() : "sans");
-
+
// we are (not anymore) building the same font over and over again
-- g_print ("Font 0x%x: '%s' size=%g (* %g)\n",
-- GPOINTER_TO_INT (f), family, state->getTransformedFontSize(), scale);
-+ f1 = &f;
-+ g_print ("Font 0x%x: '%s' size=%g (* %g)\n", GPOINTER_TO_INT (f1), family, state->getTransformedFontSize(), scale);
-
++ f1 = &f;
+ g_print ("Font 0x%x: '%s' size=%g (* %g)\n",
+- GPOINTER_TO_INT (f), family, state->getTransformedFontSize(), scale);
++ GPOINTER_TO_INT (f1), family, state->getTransformedFontSize(), scale);
+
// now try to make a fontname Dia/Pango can cope with
// strip style postfix - we already have extracted the style bits above
-@@ -353,8 +352,9 @@
+@@ -353,8 +353,9 @@ public :
if (fm[0] != 0)
fsize *= fabs(fm[3] / fm[0]);
font = dia_font_new (family, style, fsize * scale / 0.8);
@@ -57,25 +57,25 @@
g_free (family);
}
void updateTextShift(GfxState *state, double shift)
-@@ -721,11 +721,15 @@
+@@ -721,11 +722,15 @@ DiaOutputDev::drawString(GfxState *state
return;
if (!(state->getFontSize() > 0.0))
return;
- font = (DiaFont *)g_hash_table_lookup (this->font_map, state->getFont());
+gconstpointer f_1 = &state->getFont();
+// g_print ("f_1 %p\n", f_1);
-+font = (DiaFont *)g_hash_table_lookup (this->font_map, f_1);
++font = (DiaFont *)g_hash_table_lookup (this->font_map, f_1);
+// font = (DiaFont *)g_hash_table_lookup (this->font_map, &(state->getFont()));
-
+
// we have to decode the string data first
{
- GfxFont *f = state->getFont();
+// GfxFont *f = state->getFont();
-+ const std::shared_ptr<GfxFont> f = state->getFont();
++ const std::shared_ptr<GfxFont> f = state->getFont();
const char *p = s->c_str();
CharCode code;
int j = 0, m, n;
-@@ -870,8 +874,10 @@
+@@ -870,8 +875,10 @@ import_pdf(const gchar *filename, Diagra
std::unique_ptr<PDFDoc> doc;
GooString *fileName = new GooString(filename);
// no passwords yet
@@ -86,15 +86,16 @@
+ const std::optional<GooString> ownerPW;
+ const std::optional<GooString> userPW;
gboolean ret = FALSE;
-
+
// without this we will get strange crashes (at least with /O2 build)
-@@ -899,7 +905,8 @@
+@@ -899,7 +906,8 @@ import_pdf(const gchar *filename, Diagra
delete diaOut;
ret = TRUE;
}
- delete fileName;
+ doc.reset();
+ delete fileName;
-
+
return ret;
}
+