summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2018-05-27 00:48:04 -0300
committerDanilo J. S. Bellini2018-05-27 00:48:04 -0300
commit774567e375d3b9b5263f902e40e4c176250aa63d (patch)
treea07cab0fcd210f217741f418e50c46bada59e05b
parent8972616ccdc3288195e1e4dd3da984450edaf64c (diff)
downloadaur-774567e375d3b9b5263f902e40e4c176250aa63d.tar.gz
v1.4.7-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9da7e0bd7e0b..f49cadd75b67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kealib
pkgdesc = An HDF5 Based Raster File Format and its GDAL plugin
- pkgver = 1.4.6
+ pkgver = 1.4.7
pkgrel = 1
url = http://kealib.org
arch = i686
@@ -12,8 +12,8 @@ pkgbase = kealib
depends = hdf5-cpp-fortran
depends = gdal
options = !emptydirs
- source = https://bitbucket.org/chchrsc/kealib/downloads/kealib-1.4.6.tar.gz
- sha256sums = 96f6795dd961428cf12137116f9c2e3853d5a19569319b6ea76482552bc07ef3
+ source = https://bitbucket.org/chchrsc/kealib/downloads/kealib-1.4.7.tar.gz
+ sha256sums = ec38751b3b555d3a26f0c7445f2d2cd9d7c3a3502237519a206a50cb58df56ec
pkgname = kealib
diff --git a/PKGBUILD b/PKGBUILD
index ec3b9b6ea080..6e6ce8cd3a61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
pkgname=('kealib')
-pkgver=1.4.6
+pkgver=1.4.7
pkgrel=1
pkgdesc="An HDF5 Based Raster File Format and its GDAL plugin"
arch=('i686' 'x86_64')
@@ -10,7 +10,7 @@ makedepends=('hdf5-cpp-fortran' 'gdal' 'cmake')
depends=('hdf5-cpp-fortran' 'gdal')
options=(!emptydirs)
source=("https://bitbucket.org/chchrsc/kealib/downloads/kealib-$pkgver.tar.gz")
-sha256sums=('96f6795dd961428cf12137116f9c2e3853d5a19569319b6ea76482552bc07ef3')
+sha256sums=('ec38751b3b555d3a26f0c7445f2d2cd9d7c3a3502237519a206a50cb58df56ec')
_srcpath=$pkgname-$pkgver/trunk
prepare() {
@@ -25,6 +25,7 @@ build() {
cd "$srcdir/$_srcpath"
cmake -D CMAKE_INSTALL_PREFIX=/usr \
-D CMAKE_SKIP_RPATH=ON \
+ -D CMAKE_CXX_STANDARD=11 \
-D HDF5_INCLUDE_DIR=/usr/include \
-D HDF5_LIB_PATH=/usr/lib \
-D GDAL_INCLUDE_DIR=/usr/include \