summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2014-05-06 10:55:41 +0800
committerAllen Zhong2014-05-06 10:55:41 +0800
commit774a44ea6ec9099df24f9d40e88c4727f8f37586 (patch)
tree68704002c54e3e4354a513d8f454ca16584748ac
downloadaur-774a44ea6ec9099df24f9d40e88c4727f8f37586.tar.gz
newpkg: asar-apache r40-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..738f2b55db38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = asar-apache
+ pkgdesc = A System Activity Reporter of apache httpd
+ pkgver = r40
+ pkgrel = 2
+ url = http://code.google.com/p/python-asar/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = apache
+ source = http://python-asar.googlecode.com/svn-history/r40/trunk/asar-apache-agent/asar_apache_agent.c
+ source = http://python-asar.googlecode.com/svn-history/r40/trunk/asar-apache-agent/asar_apache_gather.c
+ md5sums = ae8af0c209828408496c8a09adf51102
+ md5sums = 5fdf7a14172fb6ed70c707231e57c359
+
+pkgname = asar-apache
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20fc947666b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Allen Zhong <moeallenz@gmail.com>
+pkgname=asar-apache
+pkgver=r40
+pkgrel=1
+pkgdesc="A System Activity Reporter of apache httpd"
+arch=(i686 x86_64)
+url="http://code.google.com/p/python-asar/"
+license=('GPL2')
+depends=('apache')
+source=("http://python-asar.googlecode.com/svn-history/$pkgver/trunk/asar-apache-agent/asar_apache_agent.c")
+md5sums=('ae8af0c209828408496c8a09adf51102')
+
+build() {
+ cd "$srcdir"
+
+ gcc -o asar_apache_agent asar_apache_agent.c
+}
+
+package() {
+ cd "$srcdir"
+ install -d "$pkgdir"/usr/sbin
+ install -Dm755 asar_apache_agent "$pkgdir"/usr/sbin/
+}
+