summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2019-09-15 15:01:14 -0700
committerMike Swanson2019-09-15 15:01:14 -0700
commit775654945cc78dfa70843c782f8bea311b4b7ebc (patch)
treef6de9d1105a3cc0a1f10fb008f8fa28b563b9c43
parentc8d235a4d8fa4b3c5336edbe3044a1ae3d12dec1 (diff)
downloadaur-775654945cc78dfa70843c782f8bea311b4b7ebc.tar.gz
Merge package into a non-split one
-rw-r--r--.SRCINFO56
-rw-r--r--PKGBUILD133
2 files changed, 31 insertions, 158 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 228fa9b6b194..b075e6fb0e48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
-# Generated by mksrcinfo v8
-# Sat Feb 3 07:30:28 UTC 2018
pkgbase = chocolate-doom-git
pkgdesc = Historically-accurate Doom, Heretic, Hexen, and Strife ports.
- pkgver = 3.0.0.r58.a8985916
+ pkgver = 3.0.0.r822.ee9fc21f
pkgrel = 1
url = http://www.chocolate-doom.org/
+ install = chocolate-doom.install
arch = i686
arch = x86_64
license = GPL2
@@ -14,51 +13,20 @@ pkgbase = chocolate-doom-git
depends = libsamplerate
depends = sdl2_mixer
depends = sdl2_net
- source = git+https://github.com/chocolate-doom/chocolate-doom.git
- sha512sums = SKIP
-
-pkgname = chocolate-doom-git
- pkgdesc = Doom port accurately reproducing the original DOS EXEs.
- depends = libpng
- depends = libsamplerate
- depends = sdl2_mixer
- depends = sdl2_net
- depends = chocolate-common-git
optdepends = freedm: Free deathmatch game
- optdepends = freedoom1: Free Ultimate Doom-compatible game (not vanilla compatible, but useful for mods)
- optdepends = freedoom2: Free Doom II/Final Doom-compatible game (not vanilla compatible, but useful for mods)
+ optdepends = freedoom1: Free Ultimate Doom-compatible game
+ optdepends = freedoom2: Free Doom II/Final Doom-compatible game
+ conflicts = chocolate-common
conflicts = chocolate-doom
-
-pkgname = chocolate-heretic-git
- pkgdesc = Heretic port accurately reproducing the original DOS EXEs.
- depends = libpng
- depends = libsamplerate
- depends = sdl2_mixer
- depends = sdl2_net
- depends = chocolate-common-git
- optdepends = blasphemer: Free Heretic-compatible game
conflicts = chocolate-heretic
-
-pkgname = chocolate-hexen-git
- pkgdesc = Hexen port accurately reproducing the original DOS EXEs.
- depends = libpng
- depends = libsamplerate
- depends = sdl2_mixer
- depends = sdl2_net
- depends = chocolate-common-git
conflicts = chocolate-hexen
-
-pkgname = chocolate-strife-git
- pkgdesc = Strife port accurately reproducing the original DOS EXEs.
- depends = libpng
- depends = libsamplerate
- depends = sdl2_mixer
- depends = sdl2_net
- depends = chocolate-common-git
conflicts = chocolate-strife
+ replaces = chocolate-common-git
+ replaces = chocolate-heretic-git
+ replaces = chocolate-hexen-git
+ replaces = chocolate-strife-git
+ source = git+https://github.com/chocolate-doom/chocolate-doom.git
+ sha512sums = SKIP
-pkgname = chocolate-common-git
- pkgdesc = Files shared in common with Chocolate Doom-based games.
- install = chocolate-doom.install
- conflicts = chocolate-common
+pkgname = chocolate-doom-git
diff --git a/PKGBUILD b/PKGBUILD
index f96dbdfae1e1..d255677bed62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,140 +1,45 @@
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
-pkgname=(chocolate-{doom,heretic,hexen,strife,common}-git)
-_pkgname=${pkgname[0]/-git/}
+pkgname=chocolate-doom-git
pkgdesc="Historically-accurate Doom, Heretic, Hexen, and Strife ports."
-pkgver=3.0.0.r58.a8985916
+pkgver=3.0.0.r822.ee9fc21f
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.chocolate-doom.org/"
license=('GPL2')
+install=chocolate-doom.install
depends=('libpng' 'libsamplerate' 'sdl2_mixer' 'sdl2_net')
makedepends=('git' 'python')
+optdepends=('freedm: Free deathmatch game'
+ 'freedoom1: Free Ultimate Doom-compatible game'
+ 'freedoom2: Free Doom II/Final Doom-compatible game')
+conflicts=(chocolate-common
+ chocolate-doom
+ chocolate-heretic
+ chocolate-hexen
+ chocolate-strife)
+replaces=(chocolate-common-git
+ chocolate-heretic-git
+ chocolate-hexen-git
+ chocolate-strife-git)
source=(git+https://github.com/chocolate-doom/chocolate-doom.git)
sha512sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
+ cd "${pkgname/-git//}"
local version="$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
printf %s "${version##chocolate.doom.}"
}
build() {
- cd "${_pkgname}"
+ cd "${pkgname/-git//}"
./autogen.sh --prefix=/usr
make
}
-package_chocolate-common-git() {
- pkgdesc="Files shared in common with Chocolate Doom-based games."
- conflicts=(chocolate-common)
- install=chocolate-doom.install
+package() {
+ cd "${pkgname/-git//}"
- cd "${_pkgname}"
make DESTDIR="${pkgdir}" install
- install -dm 755 "${pkgdir}"/usr/share/games/doom
-
- cd "${pkgdir}"/usr/bin
- mv chocolate-doom-setup chocolate-setup
- rm -f chocolate-{doom,heretic,hexen,strife}{,-setup}
-
- cd "${pkgdir}"/usr/share
- rm -rf bash-completion doc man/man5
- rm -rf applications/chocolate-{doom,heretic,hexen,strife}.desktop \
- applications/screensavers
- rm -rf metainfo
- cd man/man6
- rm -f chocolate-{doom,heretic,hexen,strife}{,-setup}.6
-}
-
-package_chocolate-doom-git() {
- pkgdesc="Doom port accurately reproducing the original DOS EXEs."
- depends=(${depends[@]} 'chocolate-common-git')
- optdepends=('freedm: Free deathmatch game'
- 'freedoom1: Free Ultimate Doom-compatible game (not vanilla compatible, but useful for mods)'
- 'freedoom2: Free Doom II/Final Doom-compatible game (not vanilla compatible, but useful for mods)')
- conflicts=(chocolate-doom)
-
- cd "${_pkgname}"
- make DESTDIR="${pkgdir}" install
-
- cd "${pkgdir}"/usr/bin
- rm -f chocolate-{heretic,hexen,strife,server} chocolate*setup
- ln -s chocolate{,-doom}-setup
-
- cd "${pkgdir}"/usr/share
- rm -rf doc/chocolate-{heretic,hexen,strife}
- rm -rf applications/chocolate-{setup,heretic,hexen,strife}.desktop icons
- rm -f metainfo/chocolate-{heretic,hexen,strife}.appdata.xml \
- bash-completion/completions/chocolate-{heretic,hexen,strife}
- rm -f man/man?/chocolate-{heretic,hexen,strife,setup,server}* \
- man/man5/{heretic,hexen,strife}.cfg*
-}
-
-package_chocolate-heretic-git() {
- pkgdesc="Heretic port accurately reproducing the original DOS EXEs."
- depends=(${depends[@]} 'chocolate-common-git')
- optdepends=('blasphemer: Free Heretic-compatible game')
- conflicts=(chocolate-heretic)
-
- cd "${_pkgname}"
- make DESTDIR="${pkgdir}" install
-
- cd "${pkgdir}"/usr/bin
- rm -f chocolate-{doom,hexen,strife,server} chocolate*setup
- ln -s chocolate{,-heretic}-setup
-
- cd "${pkgdir}"/usr/share
- rm -rf doc/chocolate-{doom,hexen,strife}
- rm -rf applications/chocolate-{setup,doom,hexen,strife}.desktop \
- applications/screensavers icons
- rm -f metainfo/chocolate-{doom,hexen,strife}.appdata.xml \
- bash-completion/completions/chocolate-{doom,hexen,strife}
- rm -f man/man?/chocolate-{doom,hexen,strife,setup,server}* \
- man/man5/{default,hexen,strife}.cfg*
-}
-
-package_chocolate-hexen-git() {
- pkgdesc="Hexen port accurately reproducing the original DOS EXEs."
- depends=(${depends[@]} 'chocolate-common-git')
- conflicts=(chocolate-hexen)
-
- cd "${_pkgname}"
- make DESTDIR="${pkgdir}" install
-
- cd "${pkgdir}"/usr/bin
- rm -f chocolate-{doom,heretic,strife,server} chocolate*setup
- ln -s chocolate{,-hexen}-setup
-
- cd "${pkgdir}"/usr/share
- rm -rf doc/chocolate-{doom,heretic,strife}
- rm -rf applications/chocolate-{setup,doom,heretic,strife}.desktop \
- applications/screensavers icons
- rm -f metainfo/chocolate-{doom,heretic,strife}.appdata.xml \
- bash-completion/completions/chocolate-{doom,heretic,strife}
- rm -f man/man?/chocolate-{doom,heretic,strife,setup,server}* \
- man/man5/{default,heretic,strife}.cfg*
-}
-
-package_chocolate-strife-git() {
- pkgdesc="Strife port accurately reproducing the original DOS EXEs."
- depends=(${depends[@]} 'chocolate-common-git')
- conflicts=(chocolate-strife)
-
- cd "${_pkgname}"
- make DESTDIR="${pkgdir}" install
-
- cd "${pkgdir}"/usr/bin
- rm -f chocolate-{doom,heretic,hexen,server} chocolate*setup
- ln -s chocolate{,-strife}-setup
-
- cd "${pkgdir}"/usr/share
- rm -rf doc/chocolate-{doom,heretic,hexen}
- rm -rf applications/chocolate-{setup,doom,heretic,hexen}.desktop \
- applications/screensavers icons
- rm -f metainfo/chocolate-{doom,heretic,hexen}.appdata.xml \
- bash-completion/completions/chocolate-{doom,heretic,hexen}
- rm -f man/man?/chocolate-{doom,heretic,hexen,setup,server}* \
- man/man5/{default,heretic,hexen}.cfg*
}