summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gerhard Martinussen2018-05-04 18:19:28 +0200
committerJakob Gerhard Martinussen2018-05-04 18:19:28 +0200
commit7757245739c8f866c5a10c7352a48518bf75240b (patch)
treed52b16165ad810b43318898d66ae0a9a4bb007a9
downloadaur-7757245739c8f866c5a10c7352a48518bf75240b.tar.gz
First commit adding PKGBUILD file
For now, the test suite is not executed as part of check()
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06867744a668
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = astrality-git
+ pkgdesc = templates-based configuration file manager
+ pkgver = 0.6.r130.g589b228
+ pkgrel = 1
+ url = https://astrality.readthedocs.io
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = git
+ makedepends = sed
+ depends = python
+ optdepends = libyaml: faster YAML config parsing
+ provides = astrality
+ conflicts = astrality
+ source = astrality::git+https://github.com/JakobGM/astrality.git
+ sha256sums = SKIP
+
+pkgname = astrality-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea470a8b2c0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jakob Gerhard Martinussen <jakobgm at gmail dot com>
+pkgname=astrality-git
+pkgver=0.6.r130.g589b228
+pkgrel=1
+
+pkgdesc='templates-based configuration file manager'
+url='https://astrality.readthedocs.io'
+arch=('any')
+license=('MIT')
+
+depends=('python')
+makedepends=('python-setuptools' 'git' 'sed')
+optdepends=('libyaml: faster YAML config parsing')
+
+provides=('astrality')
+conflicts=('astrality')
+
+source=('astrality::git+https://github.com/JakobGM/astrality.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd astrality
+ git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd astrality
+ python setup.py build
+}
+
+package() {
+ cd astrality
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm0644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}