summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2017-01-25 14:10:06 -0800
committerDonald Webster2017-01-25 14:25:22 -0800
commit7761e70ccdf2242f4fc4665990264f6d41fc826d (patch)
treeb9044dca54177eff7adf40a679601d085790debd
downloadaur-7761e70ccdf2242f4fc4665990264f6d41fc826d.tar.gz
Initial v1.0.0 release.
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
-rw-r--r--lazylibrarian.install15
-rw-r--r--lazylibrarian.service13
-rw-r--r--lazylibrarian.sysusers1
6 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a456efa32e5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed Jan 25 22:09:14 UTC 2017
+pkgbase = lazylibrarian
+ pkgdesc = Automatic Book Downloading via NZBs & Torrent
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/DobyTang/LazyLibrarian
+ install = lazylibrarian.install
+ arch = any
+ license = GPL3
+ depends = python2
+ provides = lazylibrarian
+ conflicts = lazylibrarian-git
+ source = https://github.com/DobyTang/LazyLibrarian/archive/v1.0.0.tar.gz
+ source = lazylibrarian.service
+ source = lazylibrarian.sysusers
+ sha256sums = c1886b60d3d1ee0cfee84e79d5f2d3d93762b80af814c919e30e27a9891adeab
+ sha256sums = 5010608e99e0242ba7c74b401efed0968984fd9a0ba1b9995dca22d6b8da8519
+ sha256sums = 94791f40c9997526304b8a18d63fd555b30871efbebbc647a4e020222967becd
+
+pkgname = lazylibrarian
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..87abb0e77adb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/LazyLibrarian/
+/*.xz
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f468138fef3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Donald Webster <fryfrog@gmail.com>
+
+pkgname=lazylibrarian
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Automatic Book Downloading via NZBs & Torrent"
+arch=('any')
+url="https://github.com/DobyTang/LazyLibrarian"
+license=('GPL3')
+depends=('python2')
+install='lazylibrarian.install'
+conflicts=('lazylibrarian-git')
+provides=('lazylibrarian')
+
+source=("https://github.com/DobyTang/LazyLibrarian/archive/v${pkgver}.tar.gz"
+ 'lazylibrarian.service'
+ 'lazylibrarian.sysusers')
+
+sha256sums=('c1886b60d3d1ee0cfee84e79d5f2d3d93762b80af814c919e30e27a9891adeab'
+ '5010608e99e0242ba7c74b401efed0968984fd9a0ba1b9995dca22d6b8da8519'
+ '1e5ee6265af4e4d8beea3cec49cbdba6624a6169edee081aa03de32965d4729d')
+
+package() {
+ install -d -m 755 "${pkgdir}/usr/lib/lazylibrarian"
+ cp -dpr --no-preserve=ownership "$srcdir/LazyLibrarian-${pkgver}"/* "${pkgdir}/usr/lib/lazylibrarian"
+
+ install -Dm644 "${srcdir}/lazylibrarian.service" "${pkgdir}/usr/lib/systemd/system/lazylibrarian.service"
+ install -Dm644 "${srcdir}/lazylibrarian.sysusers" "${pkgdir}/usr/lib/sysusers.d/lazylibrarian.conf"
+}
diff --git a/lazylibrarian.install b/lazylibrarian.install
new file mode 100644
index 000000000000..13665d4c36eb
--- /dev/null
+++ b/lazylibrarian.install
@@ -0,0 +1,15 @@
+CP_USER="lazylibrarian"
+CP_GROUP="lazylibrarian"
+CP_DIR="/var/lib/lazylibrarian"
+
+## arg 1: the new package version
+post_install() {
+ systemd-sysusers lazylibrarian.conf
+ chown -R ${CP_USER}:${CP_GROUP} ${CP_DIR}
+ echo " >> If you want a custom user or path for LazyLibrarian, remember to edit the service file as well."
+}
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ chown -R ${CP_USER}:${CP_GROUP} ${CP_DIR}
+}
diff --git a/lazylibrarian.service b/lazylibrarian.service
new file mode 100644
index 000000000000..adbe3507706e
--- /dev/null
+++ b/lazylibrarian.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=LazyLibrarian
+
+[Service]
+ExecStart=/usr/bin/python2 /opt/lazylibrarian/LazyLibrarian.py --daemon --config /opt/lazylibrarian/lazylibrarian.ini --datadir /opt/lazylibrarian/.lazylibrarian --nolaunch --quiet
+GuessMainPID=no
+Type=forking
+User=lazylibrarian
+Group=lazylibrarian
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target
diff --git a/lazylibrarian.sysusers b/lazylibrarian.sysusers
new file mode 100644
index 000000000000..84d8dea10982
--- /dev/null
+++ b/lazylibrarian.sysusers
@@ -0,0 +1 @@
+u lazylibrarian - "LazyLibrarian Server" /var/lib/lazylibrarian