summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s.2017-05-04 13:58:33 -0400
committerbrent s.2017-05-04 13:58:33 -0400
commit7766730b0671a9b92f2908aae66dea3f63511463 (patch)
tree9093d86dc8e9d2dec2efd0cb0c2d6cf4c3a07072
downloadaur-7766730b0671a9b92f2908aae66dea3f63511463.tar.gz
initial commit; setting up .gitignores and skeleton PKGBUILD
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD46
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db28b20271a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by aurpkgs
+# Thu May 04 17:58:33 UTC 2017
+pkgbase = aif-git
+ pkgdesc = An XML and python-driven rebirth of the AIF (Arch Installation Framework) project.
+ pkgver = False
+ pkgrel = 1
+ url = https://aif.square-r00t.net/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = python
+ depends = arch-install-scripts
+ depends = parted
+ depends = gptfdisk
+ optdepends = python-lxml: better xml handling
+ source = aif::git+https://git.square-r00t.net/AIF-NG
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = aif-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e16177da2907
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+*/
+.*.swp
+*.pkg.tar.xz
+src/
+pkg/
+*.tar
+*.tar.bz2
+*.tar.xz
+*.tar.gz
+*.tgz
+*.txz
+*.tbz
+*.tbz2
+*.zip
+*.run
+*.7z
+*.rar
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffd49500503a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: brent s. <bts[at]square-r00t[dot]net>
+validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
+# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
+# News updates for packages can be followed at https://devblog.square-r00t.net
+pkgname=aif-git
+pkgver=0.0001
+pkgrel=1
+pkgdesc="An XML and python-driven rebirth of the AIF (Arch Installation Framework) project."
+arch=( 'i686' 'x86_64' )
+url="https://aif.square-r00t.net/"
+license=( 'GPL3' )
+depends=( 'python' 'arch-install-scripts' 'parted' 'gptfdisk' )
+optdepends=( 'python-lxml: better xml handling' )
+_pkgname=aif
+install=
+changelog=
+noextract=()
+source=("aif::git+https://git.square-r00t.net/AIF-NG")
+# see https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git_Submodules if you require git submodules
+sha512sums=('SKIP')
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ # no tags, so number of revisions e.g. r1142.a17a017
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ ## most recent annotated tag e.g. 2.0.r6.ga17a017
+ #git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ ## most recent un-annotated tag e.g. 0.71.r115.gd95ee07
+ #git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ ## or:
+ ##git describe --long --tags | sed 's/-/.r/;s/-/./'
+ ## project uses tags with prefix. e.g. v...
+ #git describe --long | sed 's/^foo-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ ## both with fallback, e.g. 0.9.9.r27.g2b039da with tags, else r1581.2b039da
+ #( set -o pipefail
+ # git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ # printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ #)
+}
+build() {
+ cd "${srcdir}/${_pkgname}/src"
+ make prefix=${pkgdir}/usr
+}
+package() {
+ install -D -m755 ${srcdir}/${_pkgname}/src/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+ install -D -m644 ${srcdir}/${_pkgname}/docs/README.html.en ${pkgdir}/usr/share/doc/${_pkgname}/README.html
+}