summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAutumn2022-02-01 16:02:39 -0800
committerAutumn2022-02-01 16:19:52 -0800
commit777f0a697a917c2cd77a2b181d5604d6f0c92e08 (patch)
tree9a449885510f8eacf228043b90c2170eeefda178
parenta969341e64672f5f6bfcf5af6009d16d7efd1655 (diff)
downloadaur-777f0a697a917c2cd77a2b181d5604d6f0c92e08.tar.gz
fix license info
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 14 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c2c72b25dd7..48dc237e8cc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,12 @@ pkgbase = gargoyle
arch = armv6h
arch = armv7h
arch = aarch64
- license = GPL
+ license = GPL2
+ license = custom:BSD-2-Clause
+ license = custom:BSD-3-Clause
+ license = Artistic2.0
+ license = MIT
+ license = custom:OFL-1.1
makedepends = cmake
makedepends = pkgconfig
makedepends = desktop-file-utils
diff --git a/PKGBUILD b/PKGBUILD
index 3a3f0496f323..58ab21a6fd39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ pkgrel=1
pkgdesc="Interactive Fiction multi-interpreter that supports all major IF formats."
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="http://ccxvii.net/gargoyle/"
-license=('GPL')
+license=('GPL2' 'custom:BSD-2-Clause' 'custom:BSD-3-Clause' 'Artistic2.0' 'MIT' 'custom:OFL-1.1')
depends=('sdl2_mixer' 'sdl2' 'freetype2' 'qt5-base' 'fontconfig' 'libjpeg' 'libpng' 'zlib' 'hicolor-icon-theme')
makedepends=('cmake' 'pkgconfig' 'desktop-file-utils')
optdepends=('speech-dispatcher: Text-to-Speech')
@@ -49,4 +49,11 @@ package() {
# Install default config
install -dm755 "$pkgdir/etc"
install -m644 "$gsrcdir/garglk/garglk.ini" "$pkgdir/etc"
+
+ # Install licenses
+ install -dm755 "$pkgdir/usr/share/licenses/${pkgname}"
+ install -m644 "$gsrcdir/License.txt" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+ install -m644 "$gsrcdir/licenses/BSD-2-Clause.txt" "$pkgdir/usr/share/licenses/${pkgname}"
+ install -m644 "$gsrcdir/terps/advsys/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/BSD-3-Clause.txt"
+ install -m644 "$gsrcdir/licenses/Charis SIL.txt" "$pkgdir/usr/share/licenses/${pkgname}/OFL-1.1.txt"
}