summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Praehauser2021-12-22 12:47:30 +0100
committerAlexander Praehauser2021-12-22 12:47:30 +0100
commit778ece8da24033316db86c39a268a36fa59040bf (patch)
tree39b437f77ef6fafe37b2010f7e04fb59d9950384
downloadaur-778ece8da24033316db86c39a268a36fa59040bf.tar.gz
Adding PKGBUILD of the OpenMusic fork OM-Sharp
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD25
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae0c569cf69d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = om-sharp-bin
+ pkgdesc = Offshoot and inofficial successor to the OpenMusic composition software
+ pkgver = 1.5
+ pkgrel = 1
+ url = https://cac-t-u-s.github.io/
+ arch = x86_64
+ license = GPL3
+ makedepends = rsync
+ depends = desktop-file-utils
+ depends = gdk-pixbuf2
+ depends = portmidi
+ depends = libsndfile
+ optdepends = jack: JACK audio support
+ optdepends = libsamplerate: speed up audio-waveform drawing
+ provides = om-sharp-bin
+ conflicts = om-sharp-bin
+ options = !strip
+ source = https://github.com/cac-t-u-s/om-sharp/releases/download/v1.5/om-sharp-bin-1.5-1.deb
+ sha256sums = 49de7fec06b8f3d44f0abff0275fea8c6906b6fa3f97d84eb01eb52414686165
+
+pkgname = om-sharp-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2addd95e675
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Alexander Praehauser <ahprae@protonmail.com>
+_pkgbasename=om-sharp-bin
+pkgname=${_pkgbasename}
+pkgver=1.5
+pkgrel=1
+pkgdesc="Offshoot and inofficial successor to the OpenMusic composition software"
+arch=("x86_64")
+url="https://cac-t-u-s.github.io/"
+license=("GPL3")
+depends=("desktop-file-utils" "gdk-pixbuf2" "portmidi" "libsndfile")
+optdepends=("jack: JACK audio support"
+ "libsamplerate: speed up audio-waveform drawing")
+makedepends=("rsync")
+provides=("${_pkgbasename}")
+conflicts=("${_pkgbasename}")
+# Note that the openmusic executable may not be compressed/stripped.
+# (http://www.lispworks.com/kb/a15fc2ea99b4f8f5802571fe0057705a.html)
+options=(!strip)
+source=("https://github.com/cac-t-u-s/om-sharp/releases/download/v$pkgver/$_pkgbasename-$pkgver-1.deb")
+sha256sums=('49de7fec06b8f3d44f0abff0275fea8c6906b6fa3f97d84eb01eb52414686165')
+
+
+package() {
+bsdtar --no-same-owner -s/lib64/lib/ -xvf data.tar.xz -C "$pkgdir"
+}