summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2022-01-21 14:55:54 +0800
committerUniversebenzene2022-01-21 14:55:54 +0800
commit77b0955790e1a983d85fbc6e675bb6823b9d6bfb (patch)
treef4a5be391cb8afb338a43bebfdf0357d62325d2a
parent29e0c42821d0ad4987183fe6eb4eac9de6e345a2 (diff)
downloadaur-77b0955790e1a983d85fbc6e675bb6823b9d6bfb.tar.gz
Update to version 1.15.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6a67afbb8fe..bb1be11415ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-healpy
pkgdesc = Python package to manipulate healpix maps
- pkgver = 1.15.0
+ pkgver = 1.15.1
pkgrel = 1
url = http://healpy.readthedocs.io
arch = i686
@@ -8,20 +8,17 @@ pkgbase = python-healpy
license = GPL
checkdepends = python-pytest-cython
checkdepends = python-pytest-doctestplus
- checkdepends = python-pillow
checkdepends = python-requests
- makedepends = cython>=0.16
- makedepends = python-pytest-runner
- depends = python>=3.6
+ makedepends = cython
+ depends = python>=3.7
depends = python-numpy>=1.13
depends = python-scipy
depends = python-matplotlib
depends = python-astropy
depends = cfitsio
- depends = healpix>=3.60
- depends = python-six
+ depends = healpix>=3.80
optdepends = python-healpy-doc: Documentation for healpy
- source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.15.0.tar.gz
- md5sums = f0fc4e0a818fae18d349b66b05c7b178
+ source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.15.1.tar.gz
+ md5sums = d677ca493bd7694850028ce559443e9e
pkgname = python-healpy
diff --git a/PKGBUILD b/PKGBUILD
index f6a041dc5667..f596c75f7bcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-healpy
_pyname=${pkgname#python-}
-pkgver=1.15.0
+pkgver=1.15.1
pkgrel=1
pkgdesc="Python package to manipulate healpix maps"
arch=('i686' 'x86_64')
url="http://healpy.readthedocs.io"
license=('GPL')
-depends=('python>=3.6' 'python-numpy>=1.13' 'python-scipy' 'python-matplotlib' 'python-astropy' 'cfitsio' 'healpix>=3.60' 'python-six')
-makedepends=('cython>=0.16' 'python-pytest-runner')
+depends=('python>=3.7' 'python-numpy>=1.13' 'python-scipy' 'python-matplotlib' 'python-astropy' 'cfitsio' 'healpix>=3.80')
+makedepends=('cython')
optdepends=('python-healpy-doc: Documentation for healpy')
-checkdepends=('python-pytest-cython' 'python-pytest-doctestplus' 'python-pillow' 'python-requests')
+checkdepends=('python-pytest-cython' 'python-pytest-doctestplus' 'python-requests')
source=("https://files.pythonhosted.org/packages/source/h/healpy/healpy-${pkgver}.tar.gz")
-md5sums=('f0fc4e0a818fae18d349b66b05c7b178')
+md5sums=('d677ca493bd7694850028ce559443e9e')
prepare() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ sed -i 's/3.80.0/3.80/' setup.py
export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
}