summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Burobin2022-02-18 15:01:46 +0300
committerAlexander Burobin2022-02-18 15:01:46 +0300
commit77b95dabbf29b00ab7e8c25081838b1e15fb2937 (patch)
treec93461c669436e1946568adf6fba334b14bde9d5
downloadaur-77b95dabbf29b00ab7e8c25081838b1e15fb2937.tar.gz
1.6.0-alpha.4
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD30
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dbe93fdf0b8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gswatcher
+ pkgdesc = A simple game server browser and an administrative tool
+ pkgver = 1.6.0alpha.4
+ pkgrel = 1
+ url = https://gitlab.com/lxndr-ab/gswatcher
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = meson
+ makedepends = ninja
+ makedepends = vala
+ depends = libgee
+ depends = gtk4
+ depends = libadwaita
+ depends = duktape
+ depends = geoip
+ options = !strip
+ options = debug
+ source = https://gitlab.com/lxndr-ab/gswatcher/-/archive/1.6.0-alpha.4/gswatcher-1.6.0-alpha.4.tar.bz2
+ sha256sums = e3c71ebd6c965cb47e2e0d68930690e2a9425457f76c1c951ce591f8ec896e4b
+
+pkgname = gswatcher
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6552e708be20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Burobin Alexander <lxndr87i@gmail.com>
+
+pkgname="gswatcher"
+pkgver="1.6.0alpha.4"
+_pkgver="1.6.0-alpha.4"
+pkgrel=1
+
+pkgdesc="A simple game server browser and an administrative tool"
+url="https://gitlab.com/lxndr-ab/gswatcher"
+arch=(x86_64 armv7h aarch64)
+license=(GPL3)
+depends=(libgee gtk4 libadwaita duktape geoip)
+makedepends=(meson ninja vala)
+options=(!strip debug)
+
+source=("https://gitlab.com/lxndr-ab/$pkgname/-/archive/$_pkgver/$pkgname-$_pkgver.tar.bz2")
+sha256sums=('e3c71ebd6c965cb47e2e0d68930690e2a9425457f76c1c951ce591f8ec896e4b')
+
+build() {
+ local meson_options=(
+ -D tests=false
+ )
+
+ arch-meson "$pkgname-$_pkgver" build "${meson_options[@]}"
+ meson compile -C build
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}