summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Beringer2016-11-14 20:57:59 +0100
committerIan Beringer2016-11-14 20:58:15 +0100
commit77c9fc1054cef6ad7b029450cb44db1f3ce886b7 (patch)
treeb10b8987709527e97e24717db4cdd0e77f715b44
parent5449b871700503dffe9dc4218569e02a1a4e4b11 (diff)
downloadaur-77c9fc1054cef6ad7b029450cb44db1f3ce886b7.tar.gz
Update to 0.6.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--include.patch24
3 files changed, 38 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84d043b2341a..bd3dae28a585 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,31 @@
pkgbase = usbguard-git
pkgdesc = USBGuard is a software framework for implementing USB device authorization policies
- pkgver = 0.6.1.r0.gba94da3
+ pkgver = 0.6.2.r9.gf4c540d
pkgrel = 1
url = https://github.com/dkopecek/usbguard
arch = i686
arch = x86_64
license = GPL2
makedepends = git
+ makedepends = libxslt
depends = libqb-git
depends = libsodium
- depends = gcc-libs-multilib
depends = libcap-ng
depends = protobuf
+ depends = polkit
depends = qt5-base
+ depends = qt5-svg
+ depends = qt5-tools
depends = hicolor-icon-theme
+ depends = dbus-glib
provides = usbguard
conflicts = usbguard
backup = etc/usbguard/usbguard-daemon.conf
backup = etc/usbguard/rules.conf
source = usbguard::git+https://github.com/dkopecek/usbguard.git
+ source = include.patch
sha256sums = SKIP
+ sha256sums = 3a6ddb78a7f5c01a6a83c0a3337dd79a184ecb8a88d3adce1087e8beb4ca9c3f
pkgname = usbguard-git
diff --git a/PKGBUILD b/PKGBUILD
index 44503492b1d3..d89050a46d34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
pkgname=usbguard-git
_pkgname=usbguard
-pkgver=0.6.1.r0.gba94da3
+pkgver=0.6.2.r9.gf4c540d
pkgrel=1
license=('GPL2')
pkgdesc='USBGuard is a software framework for implementing USB device authorization policies'
-makedepends=("git")
-depends=("libqb-git" "libsodium" "gcc-libs-multilib" "libcap-ng" "protobuf" "qt5-base" "hicolor-icon-theme")
+makedepends=("git" "libxslt")
+depends=("libqb-git" "libsodium" "libcap-ng" "protobuf" "polkit" "qt5-base" "qt5-svg" "qt5-tools" "hicolor-icon-theme" "dbus-glib")
arch=("i686" "x86_64")
url='https://github.com/dkopecek/usbguard'
-source=("${_pkgname}::git+https://github.com/dkopecek/usbguard.git")
-sha256sums=('SKIP')
+source=("${_pkgname}::git+https://github.com/dkopecek/usbguard.git" "include.patch")
+sha256sums=('SKIP' '3a6ddb78a7f5c01a6a83c0a3337dd79a184ecb8a88d3adce1087e8beb4ca9c3f')
provides=("usbguard")
conflicts=("usbguard")
backup=(
@@ -29,6 +29,7 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
+ patch -p1 <../include.patch
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc -sbindir=/usr/bin --libdir=/usr/lib \
--enable-systemd \
diff --git a/include.patch b/include.patch
new file mode 100644
index 000000000000..bf9cf869357f
--- /dev/null
+++ b/include.patch
@@ -0,0 +1,24 @@
+diff --git a/src/Library/IPCClientPrivate.hpp b/src/Library/IPCClientPrivate.hpp
+index 728c282..9f2f0f3 100644
+--- a/src/Library/IPCClientPrivate.hpp
++++ b/src/Library/IPCClientPrivate.hpp
+@@ -33,6 +33,7 @@
+
+ #include <qb/qbipcc.h>
+ #include <qb/qbloop.h>
++#include <qb/qbhdb.h>
+
+ namespace usbguard {
+ class IPCClientPrivate
+diff --git a/src/Library/IPCServerPrivate.hpp b/src/Library/IPCServerPrivate.hpp
+index 1f93cb1..8774bbc 100644
+--- a/src/Library/IPCServerPrivate.hpp
++++ b/src/Library/IPCServerPrivate.hpp
+@@ -29,6 +29,7 @@
+
+ #include <qb/qbipcs.h>
+ #include <qb/qbloop.h>
++#include <qb/qbhdb.h>
+
+ #include "Devices.pb.h"
+ #include "Policy.pb.h"