summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAsger Hautop Drewsen2018-03-07 17:26:53 +0100
committerAsger Hautop Drewsen2018-03-07 17:26:53 +0100
commit77cce400e61d9266981af94f5f9ec46d1ab1e157 (patch)
tree12b87d7deedd610b50cbd647a49a0ac422c9b9da
downloadaur-77cce400e61d9266981af94f5f9ec46d1ab1e157.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e467631dd1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = theos-git
+ pkgdesc = A cross-platform suite of tools for building and deploying software for iOS and other platforms
+ pkgver = 2.3.r10.g7a9ec0e
+ pkgrel = 1
+ url = https://theos.github.io/
+ arch = any
+ license = GPL3
+ depends = perl
+ depends = perl-compress-raw-lzma
+ optdepends = theos-ios-toolchain: For compiling for iOS
+ optdepends = theos-ios-sdks: For compiling for iOS
+ provides = theos
+ source = git+https://github.com/theos/theos
+ sha256sums = SKIP
+
+pkgname = theos-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ceb2a879209a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Asger Hautop Drewsen <asgerdrewsen@gmail.com>
+
+pkgname=theos-git
+pkgver=2.3.r10.g7a9ec0e
+pkgrel=1
+pkgdesc="A cross-platform suite of tools for building and deploying software for iOS and other platforms"
+arch=('any')
+url="https://theos.github.io/"
+license=('GPL3')
+depends=('perl' 'perl-compress-raw-lzma')
+makedepends=()
+optdepends=(
+'theos-ios-toolchain: For compiling for iOS'
+'theos-ios-sdks: For compiling for iOS'
+)
+provides=('theos')
+source=("git+https://github.com/theos/theos")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "theos"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/theos"
+ git submodule update --init --recursive
+
+ mkdir -p "${pkgdir}/opt"
+ cp -dpr --no-preserve=ownership "${srcdir}/theos" "${pkgdir}/opt"
+}