summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValentin Hăloiu2016-10-16 20:57:51 +0300
committerValentin Hăloiu2016-10-16 22:44:00 +0300
commit77d3b036fb3f0af767a1075e902b6e52855940a3 (patch)
treed12b99592c2445df5d60a14a87ca6f705bf31075
parent62adde822ba1dcfc6f1aad7409ad4ed0fb3509e4 (diff)
downloadaur-77d3b036fb3f0af767a1075e902b6e52855940a3.tar.gz
Update PKGBUILD to fix compilation issues
-rw-r--r--.SRCINFO50
-rw-r--r--0001-Add-a-way-to-filter-window-system-events.patch117
-rw-r--r--PKGBUILD84
3 files changed, 86 insertions, 165 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b8cc9979326..d2551726044a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,43 +1,59 @@
# Generated by mksrcinfo v8
-# Mon Feb 1 21:55:12 UTC 2016
+# Sun Oct 16 19:43:39 UTC 2016
pkgbase = qt5-base-git
pkgdesc = A cross-platform application and UI framework
pkgver = git
- pkgrel = 1
+ pkgrel = 2
url = https://qt-project.org/
arch = i686
arch = x86_64
license = GPL3
- license = LGPL
- makedepends = git
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = mtdev
+ makedepends = libfbclient
+ makedepends = libmariadbclient
+ makedepends = sqlite
+ makedepends = unixodbc
makedepends = postgresql-libs
- makedepends = gtk2
- depends = dbus
+ makedepends = alsa-lib
+ makedepends = gst-plugins-base-libs
+ makedepends = gtk3
+ makedepends = libpulse
+ makedepends = cups
+ makedepends = freetds
+ makedepends = git
+ depends = libjpeg-turbo
depends = xcb-util-keysyms
- depends = xcb-util-wm
- depends = xcb-util-image
- depends = libxext
- depends = inputproto
depends = libgl
- depends = libxkbcommon
- depends = systemd
- depends = libpng
- depends = sqlite
depends = fontconfig
- depends = icu
+ depends = xcb-util-wm
depends = libxrender
+ depends = libxi
+ depends = sqlite
+ depends = xcb-util-image
+ depends = icu
+ depends = tslib
depends = libinput
- depends = qtchooser
- optdepends = qtchooser: set the default Qt toolkit
+ depends = libsm
+ depends = libxkbcommon-x11
+ depends = libproxy
+ optdepends = qt5-svg: to use SVG icon themes
optdepends = postgresql-libs: PostgreSQL driver
optdepends = libmariadbclient: MariaDB driver
optdepends = unixodbc: ODBC driver
optdepends = libfbclient: Firebird/iBase driver
+ optdepends = freetds: MS SQL driver
+ optdepends = mtdev: evdev plugin
+ optdepends = gtk3: GTK platform plugin
provides = qt5-base
conflicts = qt5-base
conflicts = qtchooser
source = qt5-base::git://code.qt.io/qt/qtbase.git#branch=dev
+ source = qtbug-55530.patch::https://github.com/qt/qtbase/commit/f71aa4813.patch
sha256sums = SKIP
+ sha256sums = ea4758d296fc6af957f86858601b56829c2a04cf9adc5c4119810d341b865212
pkgname = qt5-base-git
diff --git a/0001-Add-a-way-to-filter-window-system-events.patch b/0001-Add-a-way-to-filter-window-system-events.patch
deleted file mode 100644
index 58de8ad00666..000000000000
--- a/0001-Add-a-way-to-filter-window-system-events.patch
+++ /dev/null
@@ -1,117 +0,0 @@
-From 28e39706a1a922d5c1054ad3243bac8b2708dc56 Mon Sep 17 00:00:00 2001
-From: Giulio Camuffo <giulio.camuffo@jollamobile.com>
-Date: Wed, 22 Apr 2015 13:39:39 +0300
-Subject: [PATCH] Add a way to filter window system events
-
-This change introduces the class QWindowSystemEventHandler
-which can be used to hook into QWindowSystemInterfacePrivate to
-filter and dispatch window system events.
-One use case is to intercept key events from the underlying system
-in QtCompositor and feed them into the xkbcommon state, and to modify
-the events based on the resulting state.
-
-Change-Id: I829eb7d960420135990fb0f6db54c14eea3e8e48
-Reviewed-by: Laszlo Agocs <laszlo.agocs@theqtcompany.com>
-Reviewed-by: Gunnar Sletta <gunnar@sletta.org>
----
- src/gui/kernel/qwindowsysteminterface.cpp | 34 +++++++++++++++++++++++++++++--
- src/gui/kernel/qwindowsysteminterface_p.h | 13 ++++++++++++
- 2 files changed, 45 insertions(+), 2 deletions(-)
-
-diff --git a/src/gui/kernel/qwindowsysteminterface.cpp b/src/gui/kernel/qwindowsysteminterface.cpp
-index 850b69d..2ea1ccd 100644
---- a/src/gui/kernel/qwindowsysteminterface.cpp
-+++ b/src/gui/kernel/qwindowsysteminterface.cpp
-@@ -48,6 +48,7 @@ QElapsedTimer QWindowSystemInterfacePrivate::eventTime;
- bool QWindowSystemInterfacePrivate::synchronousWindowsSystemEvents = false;
- QWaitCondition QWindowSystemInterfacePrivate::eventsFlushed;
- QMutex QWindowSystemInterfacePrivate::flushEventMutex;
-+QWindowSystemEventHandler *QWindowSystemInterfacePrivate::eventHandler;
-
- //------------------------------------------------------------
- //
-@@ -621,14 +622,32 @@ bool QWindowSystemInterface::sendWindowSystemEvents(QEventLoop::ProcessEventsFla
- QWindowSystemInterfacePrivate::getWindowSystemEvent();
- if (!event)
- break;
-- nevents++;
-- QGuiApplicationPrivate::processWindowSystemEvent(event);
-+
-+ if (QWindowSystemInterfacePrivate::eventHandler) {
-+ if (QWindowSystemInterfacePrivate::eventHandler->sendEvent(event))
-+ nevents++;
-+ } else {
-+ nevents++;
-+ QGuiApplicationPrivate::processWindowSystemEvent(event);
-+ }
- delete event;
- }
-
- return (nevents > 0);
- }
-
-+void QWindowSystemInterfacePrivate::installWindowSystemEventHandler(QWindowSystemEventHandler *handler)
-+{
-+ if (!eventHandler)
-+ eventHandler = handler;
-+}
-+
-+void QWindowSystemInterfacePrivate::removeWindowSystemEventhandler(QWindowSystemEventHandler *handler)
-+{
-+ if (eventHandler == handler)
-+ eventHandler = 0;
-+}
-+
- void QWindowSystemInterface::setSynchronousWindowsSystemEvents(bool enable)
- {
- QWindowSystemInterfacePrivate::synchronousWindowsSystemEvents = enable;
-@@ -852,4 +871,15 @@ Q_GUI_EXPORT void qt_handleTouchEvent(QWindow *w, QTouchDevice *device,
- QWindowSystemInterface::handleTouchEvent(w, device, touchPointList(points), mods);
- }
-
-+QWindowSystemEventHandler::~QWindowSystemEventHandler()
-+{
-+ QWindowSystemInterfacePrivate::removeWindowSystemEventhandler(this);
-+}
-+
-+bool QWindowSystemEventHandler::sendEvent(QWindowSystemInterfacePrivate::WindowSystemEvent *e)
-+{
-+ QGuiApplicationPrivate::processWindowSystemEvent(e);
-+ return true;
-+}
-+
- QT_END_NAMESPACE
-diff --git a/src/gui/kernel/qwindowsysteminterface_p.h b/src/gui/kernel/qwindowsysteminterface_p.h
-index 2ec402a..f51c726 100644
---- a/src/gui/kernel/qwindowsysteminterface_p.h
-+++ b/src/gui/kernel/qwindowsysteminterface_p.h
-@@ -54,6 +54,8 @@
-
- QT_BEGIN_NAMESPACE
-
-+class QWindowSystemEventHandler;
-+
- class Q_GUI_EXPORT QWindowSystemInterfacePrivate {
- public:
- enum EventType {
-@@ -487,6 +489,17 @@ public:
- static QMutex flushEventMutex;
-
- static QList<QTouchEvent::TouchPoint> convertTouchPoints(const QList<QWindowSystemInterface::TouchPoint> &points, QEvent::Type *type);
-+
-+ static void installWindowSystemEventHandler(QWindowSystemEventHandler *handler);
-+ static void removeWindowSystemEventhandler(QWindowSystemEventHandler *handler);
-+ static QWindowSystemEventHandler *eventHandler;
-+};
-+
-+class Q_GUI_EXPORT QWindowSystemEventHandler
-+{
-+public:
-+ virtual ~QWindowSystemEventHandler();
-+ virtual bool sendEvent(QWindowSystemInterfacePrivate::WindowSystemEvent *event);
- };
-
- QT_END_NAMESPACE
---
-2.6.4
-
diff --git a/PKGBUILD b/PKGBUILD
index a8cd8c49421b..901d4ac6f472 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Riley Trautman <asonix.dev@gmail.com>
+# Maintainer: Valentin Hăloiu <vially.ichb+aur@gmail.com>
+# Contributor: Riley Trautman <asonix.dev@gmail.com>
# Contributor: Jerome Leclanche <jerome@leclan.ch>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
@@ -6,70 +7,91 @@
_pkgname=qt5-base
pkgname=$_pkgname-git
pkgver=git
-pkgrel=1
-pkgdesc="A cross-platform application and UI framework"
+pkgrel=2
arch=("i686" "x86_64")
-url="https://qt-project.org/"
-license=("GPL3" "LGPL")
-depends=(
-"dbus" "xcb-util-keysyms" "xcb-util-wm" "xcb-util-image"
-"libxext" "inputproto" "libgl" "libxkbcommon" "systemd"
-"libpng" "sqlite" "fontconfig" "icu" "libxrender" "libinput" "qtchooser"
-)
-makedepends=("git" "postgresql-libs" "gtk2")
-optdepends=(
-"qtchooser: set the default Qt toolkit"
-"postgresql-libs: PostgreSQL driver"
-"libmariadbclient: MariaDB driver"
-"unixodbc: ODBC driver"
-"libfbclient: Firebird/iBase driver"
-)
+url='https://qt-project.org/'
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
+pkgdesc="A cross-platform application and UI framework"
+depends=('libjpeg-turbo' 'xcb-util-keysyms' 'libgl' 'fontconfig'
+ 'xcb-util-wm' 'libxrender' 'libxi' 'sqlite' 'xcb-util-image' 'icu'
+ 'tslib' 'libinput' 'libsm' 'libxkbcommon-x11' 'libproxy')
+makedepends=('mtdev' 'libfbclient' 'libmariadbclient' 'sqlite' 'unixodbc' 'postgresql-libs' 'alsa-lib' 'gst-plugins-base-libs'
+ 'gtk3' 'libpulse' 'cups' 'freetds' 'git')
+optdepends=('qt5-svg: to use SVG icon themes'
+ 'postgresql-libs: PostgreSQL driver'
+ 'libmariadbclient: MariaDB driver'
+ 'unixodbc: ODBC driver'
+ 'libfbclient: Firebird/iBase driver'
+ 'freetds: MS SQL driver'
+ 'mtdev: evdev plugin'
+ 'gtk3: GTK platform plugin')
provides=("$_pkgname")
conflicts=("$_pkgname" "qtchooser")
-source=("$_pkgname::git://code.qt.io/qt/qtbase.git#branch=dev")
+source=("$_pkgname::git://code.qt.io/qt/qtbase.git#branch=dev"
+ qtbug-55530.patch::'https://github.com/qt/qtbase/commit/f71aa4813.patch')
-sha256sums=("SKIP")
+sha256sums=('SKIP'
+ 'ea4758d296fc6af957f86858601b56829c2a04cf9adc5c4119810d341b865212')
pkgver() {
cd "$srcdir/$_pkgname"
- # cutting off 'foo-' prefix that presents in the git tag
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd "$srcdir/$_pkgname"
- sed -i "s|-O2|${CXXFLAGS}|" mkspecs/common/{g++,gcc}-base.conf
- sed -i "/^QMAKE_LFLAGS_RPATH/s| -Wl,-rpath,||g" "mkspecs/common/gcc-base-unix.conf"
- sed -i "/^QMAKE_LFLAGS\s/s|+=|+= ${LDFLAGS}|g" "mkspecs/common/gcc-base.conf"
+
+ sed -i "s|-O2|${CXXFLAGS}|" mkspecs/common/gcc-base.conf
+
+ # Build qmake using Arch {C,LD}FLAGS
+ # This also sets default {C,CXX,LD}FLAGS for projects built using qmake
+ sed -i -e "s|^\(QMAKE_CFLAGS_RELEASE.*\)|\1 ${CFLAGS}|" \
+ mkspecs/common/gcc-base.conf
+ sed -i -e "s|^\(QMAKE_LFLAGS_RELEASE.*\)|\1 ${LDFLAGS}|" \
+ mkspecs/common/g++-unix.conf
+
+ # Use python2 for Python 2.x
+ find . -name '*.py' -exec sed -i \
+ 's|#![ ]*/usr/bin/python$|&2|;s|#![ ]*/usr/bin/env python$|&2|' {} +
+
+ # Fix resolution of OPENSSL_LIBS
+ patch -p1 -i ../qtbug-55530.patch
}
build() {
cd "$srcdir/$_pkgname"
- ./configure -confirm-license -opensource \
+ PYTHON=/usr/bin/python2 ./configure -I/usr/include/mysql -confirm-license -opensource -v \
-prefix /usr \
- -bindir /usr/lib/qt/bin \
-docdir /usr/share/doc/qt \
-headerdir /usr/include/qt \
-archdatadir /usr/lib/qt \
-datadir /usr/share/qt \
-sysconfdir /etc/xdg \
-examplesdir /usr/share/doc/qt/examples \
+ -plugin-sql-{psql,mysql,sqlite,odbc,ibase} \
-system-sqlite \
-openssl-linked \
-nomake examples \
- -nomake tests \
-no-rpath \
-optimized-qmake \
-dbus-linked \
- -reduce-relocations \
- -egl \
- -eglfs \
- -libinput
+ -system-harfbuzz \
+ -journald \
+ -no-use-gold-linker \
+ -reduce-relocations
+
make
}
package() {
cd "$srcdir/$_pkgname"
make INSTALL_ROOT="$pkgdir" install
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
}