summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeph2017-06-22 17:06:22 +0000
committerZeph2017-06-22 17:06:22 +0000
commit77e0c06df914fc64c0a080cdcdff5cf453591562 (patch)
tree54d74dc1dfb34818e9357b8f3071e5526eb09a1a
parent75a7bbac347b11adc76a346b596b44437263e256 (diff)
downloadaur-77e0c06df914fc64c0a080cdcdff5cf453591562.tar.gz
Last git version
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD21
2 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6eb0aa82b3b2..229f365151b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = rabbitvcs
pkgdesc = A project with the goal of developing a collection of utilities to allow for better client integration with some of the popular version control systems (core)
pkgver = 0.16
- pkgrel = 1
- url = http://rabbitvcs.org/
+ pkgrel = 2
+ url = https://github.com/rabbitvcs/rabbitvcs
install = rabbitvcs.install
changelog = rabbitvcs.changelog
arch = any
@@ -16,9 +16,10 @@ pkgbase = rabbitvcs
depends = python2-configobj
depends = python2-simplejson
depends = python2-gtkspellcheck
+ depends = tk
optdepends = meld: graphical diff viewer
- source = https://github.com/rabbitvcs/rabbitvcs/archive/v0.16.tar.gz
- md5sums = 25376cff136ad2fac901ff88e07893ef
+ source = rabbitvcs-0.16-2.tar.gz::https://github.com/rabbitvcs/rabbitvcs/archive/4e94b82e34b409f0baced88521a6e03cb29c4155.tar.gz
+ md5sums = 9669132c6ef3f21ecfe1fd96b9be3e0d
pkgname = rabbitvcs
diff --git a/PKGBUILD b/PKGBUILD
index 4f3fa20fa402..583b1c7e07ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,34 @@
pkgname=rabbitvcs
pkgver=0.16
-pkgrel=1
+pkgrel=2
pkgdesc="A project with the goal of developing a collection of utilities to allow for better client integration with some of the popular version control systems (core)"
arch=('any')
-url="http://rabbitvcs.org/"
+#url="http://rabbitvcs.org/"
+url="https://github.com/rabbitvcs/rabbitvcs"
install=${pkgname}.install
changelog=${pkgname}.changelog
-depends=('git' 'pygtk' 'python2-pysvn' 'python2-dulwich' 'python2-gobject2' 'python2-configobj' 'python2-simplejson' 'python2-gtkspellcheck')
+depends=('git' 'pygtk' 'python2-pysvn' 'python2-dulwich' 'python2-gobject2' 'python2-configobj' 'python2-simplejson' 'python2-gtkspellcheck' 'tk')
optdepends=('meld: graphical diff viewer')
makedepends=('python2-setuptools')
license=('GPL')
-source=("https://github.com/rabbitvcs/rabbitvcs/archive/v0.16.tar.gz")
-md5sums=('25376cff136ad2fac901ff88e07893ef')
+_gitcommit="4e94b82e34b409f0baced88521a6e03cb29c4155"
+if [ "${_gitcommit}" != "" ]; then
+ source=("rabbitvcs-$pkgver-$pkgrel.tar.gz::$url/archive/$_gitcommit.tar.gz")
+else
+ source=("rabbitvcs-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+fi
+md5sums=('9669132c6ef3f21ecfe1fd96b9be3e0d')
+#md5sums=('SKIP')
build() {
+ if [ "$_gitcommit" != "" ]; then
+ mv "$srcdir/rabbitvcs-$_gitcommit" "$srcdir/rabbitvcs-$pkgver"
+ fi
cd "$srcdir/$pkgname-$pkgver"
sed -i "s#env python#env python2#" setup.py
+ sed -i "s#!= 'Darwin'#== 'toto'#" setup.py
find . -name "*.py" | xargs grep -l sys.executable | xargs sed -i 's|sys\.executable|"/usr/bin/python2"|g'
python2 setup.py build
}