summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Lui Geh2020-01-28 15:57:10 -0300
committerRenato Lui Geh2020-01-28 15:57:10 -0300
commit77e6c0d1ff5d57462152146151d24b781d508ecc (patch)
tree01db85493397b805ba00017b944990b83b36a3be
downloadaur-77e6c0d1ff5d57462152146151d24b781d508ecc.tar.gz
Create PKGBUILD
Signed-off-by: Renato Lui Geh <renatogeh@gmail.com>
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD27
-rwxr-xr-xclean.sh2
-rw-r--r--instructions.txt7
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dff3873f7a33
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = python-spflow
+ pkgdesc = Sum-Product Flow: An Easy and Extensible Library for Sum-Product Networks
+ pkgver = 0.0.39
+ pkgrel = 1
+ url = https://github.com/SPFlow/SPFlow
+ arch = any
+ license = Apache 2.0
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-statsmodels
+ depends = python-networkx
+ depends = python-joblib
+ depends = python-matplotlib
+ depends = python-pydot
+ depends = python-lark-parser
+ depends = python-tqdm
+ depends = python-sympy
+ depends = python-pyqt5
+ depends = python-pytest
+ depends = python-ete
+ depends = python-arff
+ source = https://files.pythonhosted.org/packages/76/49/6b37eaa9bf8c758b99c3f297b39d81bdc5b07329ac674659d67f56493ead/spflow-0.0.39.tar.gz
+ sha256sums = a32a237c4ca01742a5dc4cf5ef895423d8275df8d9fac43f3e44e19ee1931a6e
+
+pkgname = python-spflow
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f27a90be6cf4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Renato Lui Geh <renatogeh at gmail dot com>
+
+pkgname=python-spflow
+_pypiname=${pkgname/python-/}
+pkgver=0.0.39
+pkgrel=1
+pkgdesc="Sum-Product Flow: An Easy and Extensible Library for Sum-Product Networks"
+arch=('any')
+url="https://github.com/SPFlow/SPFlow"
+license=('Apache 2.0')
+depends=('python' 'python-numpy' 'python-scipy' 'python-statsmodels' 'python-networkx'
+ 'python-joblib' 'python-matplotlib' 'python-pydot' 'python-lark-parser' 'python-tqdm'
+ 'python-sympy' 'python-pyqt5' 'python-pytest' 'python-ete' 'python-arff')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/76/49/6b37eaa9bf8c758b99c3f297b39d81bdc5b07329ac674659d67f56493ead/${_pypiname}-${pkgver}.tar.gz")
+sha256sums=('a32a237c4ca01742a5dc4cf5ef895423d8275df8d9fac43f3e44e19ee1931a6e')
+
+build() {
+ cd $srcdir/${_pypiname}-${pkgver}
+ python3 setup.py build
+}
+
+package() {
+ cd $srcdir/${_pypiname}-${pkgver}
+ python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+
diff --git a/clean.sh b/clean.sh
new file mode 100755
index 000000000000..e0c591563771
--- /dev/null
+++ b/clean.sh
@@ -0,0 +1,2 @@
+#!/bin/bash
+rm pkg src python-spflow*.tar.xz spflow*.tar.gz -rf
diff --git a/instructions.txt b/instructions.txt
new file mode 100644
index 000000000000..9c18d5e34dd5
--- /dev/null
+++ b/instructions.txt
@@ -0,0 +1,7 @@
+For maintainers and contributors:
+
+How to build and update:
+1. makepkg -s
+2. makepkg --printsrcinfo > .SRCINFO
+3. namcap PKGBUILD
+4. namcap python-spflow*.pkg.tar.xz