summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Icenhour2021-02-02 23:07:58 -0600
committerChris Icenhour2021-02-02 23:07:58 -0600
commit780e3964f0bb575fb8130add4537d09b9f98740b (patch)
tree4996d845b48ef74732dad611bd912cb6346bf9a4
parent675c0c6d21e252b8e11d483386963bbb6d89e3be (diff)
downloadaur-780e3964f0bb575fb8130add4537d09b9f98740b.tar.gz
Update to 0.0.27 and remove patch
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
-rw-r--r--fix_index_js.patch17
3 files changed, 7 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c6a5cc1cba4..a6beacc3f43d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = coinmon
pkgdesc = Cryptocurrency price monitoring tool
- pkgver = 0.0.24
+ pkgver = 0.0.27
pkgrel = 1
url = https://github.com/bichenkk/coinmon
arch = any
license = MIT
makedepends = npm
depends = nodejs
- noextract = coinmon-0.0.24.tgz
- noextract = fix_index_js.patch
- source = https://registry.npmjs.org/coinmon/-/coinmon-0.0.24.tgz
- source = fix_index_js.patch
- sha512sums = a5bff3925c24c99addc50075ce6ea7e3a87e36b1cf5be2f41fc43d8a4a7cbf7d4010b81a66553b73fd00af017ab0009d3039aeadf18fda538ab04367bfbc4dde
- sha512sums = 1a6baffb1a0103adb5dd3aea35078b8fbaa40400a3fd44c99d6cf15da9c8f49a1851ff86365e317731074aaef30989b1cd8f03c4235076324de1f43a316b0047
+ noextract = coinmon-0.0.27.tgz
+ source = https://registry.npmjs.org/coinmon/-/coinmon-0.0.27.tgz
+ sha512sums = 68ec43cb7a0052ee682a98dbf99ad080eb93fb204fc5b68e73808c2c3f9cf2e2b20db02875fff45de7b9df156286a790b63bdd097b33a009cc36d2a277efccac
pkgname = coinmon
diff --git a/PKGBUILD b/PKGBUILD
index edb37aaa81ae..08489ee91078 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Daniel M. Capella <polyzen@archlinux.org>
pkgname=coinmon
-pkgver=0.0.24
+pkgver=0.0.27
pkgrel=1
pkgdesc='Cryptocurrency price monitoring tool'
arch=('any')
@@ -10,10 +10,9 @@ url=https://github.com/bichenkk/coinmon
license=('MIT')
depends=('nodejs')
makedepends=('npm')
-source=("https://registry.npmjs.org/coinmon/-/coinmon-$pkgver.tgz" "fix_index_js.patch")
+source=("https://registry.npmjs.org/coinmon/-/coinmon-$pkgver.tgz")
noextract=("${source[@]##*/}")
-sha512sums=('a5bff3925c24c99addc50075ce6ea7e3a87e36b1cf5be2f41fc43d8a4a7cbf7d4010b81a66553b73fd00af017ab0009d3039aeadf18fda538ab04367bfbc4dde'
- '1a6baffb1a0103adb5dd3aea35078b8fbaa40400a3fd44c99d6cf15da9c8f49a1851ff86365e317731074aaef30989b1cd8f03c4235076324de1f43a316b0047')
+sha512sums=('68ec43cb7a0052ee682a98dbf99ad080eb93fb204fc5b68e73808c2c3f9cf2e2b20db02875fff45de7b9df156286a790b63bdd097b33a009cc36d2a277efccac')
package() {
npm install -g --user root --prefix "$pkgdir"/usr --ignore-scripts --production coinmon-$pkgver.tgz
@@ -38,5 +37,4 @@ package() {
chmod 755 $pkgdir/usr/bin
find $pkgdir/usr/lib/node_modules -type d -exec chmod 755 {} +
- patch -p1 -d "$pkgdir/usr/lib/node_modules/$pkgname/" < $srcdir/fix_index_js.patch
}
diff --git a/fix_index_js.patch b/fix_index_js.patch
deleted file mode 100644
index b82ab13bf37b..000000000000
--- a/fix_index_js.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/src/index.js b/src/index.js
-index db0fe1f..4d6cddc 100755
---- a/src/index.js
-+++ b/src/index.js
-@@ -204,9 +204,9 @@ axios.get(sourceUrl)
- const defaultValues = [
- record.rank,
- record.symbol,
-- record.price.toFixed(4),
-- getColoredChangeValueText(record.percent_change_24h.toFixed(2)),
-- record.vwap.toFixed(2),
-+ record.price && record.price.toFixed(4),
-+ getColoredChangeValueText(record.percent_change_24h && record.percent_change_24h.toFixed(2)),
-+ record.vwap && record.vwap.toFixed(2),
- formatNumber(record.market_cap),
- formatNumber(record.supply),
- formatNumber(record.volume),