summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex J. Malozemoff2017-05-31 10:35:43 -0700
committerAlex J. Malozemoff2017-05-31 10:35:43 -0700
commit781213b1c614d97fd746c2b0008497fb8aad0f66 (patch)
tree4bca16b1b821566f7dadefd954c23fc69e60304d
parent427fecba97421ed7712ad8f3b534716e74cdffe1 (diff)
downloadaur-781213b1c614d97fd746c2b0008497fb8aad0f66.tar.gz
add happy to makedeps
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 443536ea0163..b9d6b6061f1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = matterhorn-git
pkgdesc = A terminal-based chat client for MatterMost
pkgver = 30802.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/matterhorn-chat/matterhorn
arch = x86_64
license = BSD
makedepends = git
makedepends = cabal-install
makedepends = ghc
+ makedepends = happy
provides = matterhorn
source = matterhorn::git+https://github.com/matterhorn-chat/matterhorn.git
source = mattermost-api::git+https://github.com/matterhorn-chat/mattermost-api.git
diff --git a/PKGBUILD b/PKGBUILD
index f339b5fe2544..939a9036e81f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,17 +8,18 @@ pkgver() {
git describe --long --tags | cut -d- -f1
}
-pkgrel=1
+pkgrel=2
pkgdesc='A terminal-based chat client for MatterMost'
arch=('x86_64')
url="https://github.com/matterhorn-chat/matterhorn"
license=('BSD')
-makedepends=('git' 'cabal-install' 'ghc')
+makedepends=('git' 'cabal-install' 'ghc' 'happy')
source=("$_pkgname::git+https://github.com/matterhorn-chat/matterhorn.git"
"mattermost-api::git+https://github.com/matterhorn-chat/mattermost-api.git")
md5sums=('SKIP'
'SKIP')
provides=('matterhorn')
+conficts=('matterhorn')
build() {
cd "$srcdir/$_pkgname"