summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Wieczorek2016-05-15 19:51:47 +0200
committerMarcin Wieczorek2016-05-15 19:51:47 +0200
commit781683cce4a7b32d3bcf4c3fbfc47b7d9a15ddc2 (patch)
treee16c7eddaff967584c037de9d74a42d5d0516759
parentb53d69304d1f49c52495be6d7f8946f9aabf02d4 (diff)
downloadaur-781683cce4a7b32d3bcf4c3fbfc47b7d9a15ddc2.tar.gz
Fixed line endings.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--multiuser.patch132
3 files changed, 68 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 598455b55eb4..899c0c651b2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,7 +14,7 @@ pkgbase = supermodel-svn
source = multiuser.patch
source = supermodel-svn::svn+https://svn.code.sf.net/p/model3emu/code/trunk
md5sums = ea8274c2a37acddd026fce9c831530cc
- md5sums = c2384ade773d1534b00e935cb3d5b70c
+ md5sums = 2169d888da85c9baf9f55fc18c738ef8
md5sums = SKIP
pkgname = supermodel-svn
diff --git a/PKGBUILD b/PKGBUILD
index c6dcadeeb243..31b6c71987f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ source=('supermodel.sh'
"${pkgname}::svn+https://svn.code.sf.net/p/model3emu/code/trunk")
md5sums=('ea8274c2a37acddd026fce9c831530cc'
- 'c2384ade773d1534b00e935cb3d5b70c'
+ '2169d888da85c9baf9f55fc18c738ef8'
'SKIP')
MAKEFLAGS="-j1"
diff --git a/multiuser.patch b/multiuser.patch
index 269c4adab39f..bd3452d0925f 100644
--- a/multiuser.patch
+++ b/multiuser.patch
@@ -1,75 +1,75 @@
--- a/Src/OSD/SDL/Main.cpp 2016-05-15 18:16:43.001377932 +0200
+++ b/Src/OSD/SDL/Main.cpp 2016-05-15 18:21:03.166635163 +0200
@@ -512,8 +512,6 @@
- Configuration file management and input settings.
- ******************************************************************************/
-
--static const char s_configFilePath[] = { "Config/Supermodel.ini" };
--
- // Create and configure inputs
- static bool ConfigureInputs(CInputs *Inputs, bool configure)
- {
+ Configuration file management and input settings.
+ ******************************************************************************/
+
+-static const char s_configFilePath[] = { "Config/Supermodel.ini" };
+-
+ // Create and configure inputs
+ static bool ConfigureInputs(CInputs *Inputs, bool configure)
+ {
@@ -523,6 +521,9 @@
- ";\n"
- };
-
-+ char s_configFilePath[512];
-+ sprintf(s_configFilePath, "%s/.supermodel/supermodel.ini", getenv("HOME"));
-+
- // Open and parse configuration file
- CINIFile INI;
- INI.Open(s_configFilePath); // doesn't matter if it exists or not, will get overwritten
+ ";\n"
+ };
+
++ char s_configFilePath[512];
++ sprintf(s_configFilePath, "%s/.supermodel/supermodel.ini", getenv("HOME"));
++
+ // Open and parse configuration file
+ CINIFile INI;
+ INI.Open(s_configFilePath); // doesn't matter if it exists or not, will get overwritten
@@ -624,6 +625,9 @@
- // Read settings (from a specific section) from the config file
- static void ReadConfigFile(const char *section)
- {
-+ char s_configFilePath[512];
-+ sprintf(s_configFilePath, "%s/.supermodel/supermodel.ini", getenv("HOME"));
-+
- CINIFile INI;
-
- INI.Open(s_configFilePath);
+ // Read settings (from a specific section) from the config file
+ static void ReadConfigFile(const char *section)
+ {
++ char s_configFilePath[512];
++ sprintf(s_configFilePath, "%s/.supermodel/supermodel.ini", getenv("HOME"));
++
+ CINIFile INI;
+
+ INI.Open(s_configFilePath);
@@ -719,8 +723,8 @@
- {
- CBlockFile SaveState;
-
-- char filePath[24];
-- sprintf(filePath, "Saves/%s.st%d", Model3->GetGameInfo()->id, s_saveSlot);
-+ char filePath[512];
-+ sprintf(filePath, "%s/.supermodel/saves/%s.st%d", getenv("HOME"), Model3->GetGameInfo()->id, s_saveSlot);
- if (OKAY != SaveState.Create(filePath, "Supermodel Save State", "Supermodel Version " SUPERMODEL_VERSION))
- {
- ErrorLog("Unable to save state to '%s'.", filePath);
+ {
+ CBlockFile SaveState;
+
+- char filePath[24];
+- sprintf(filePath, "Saves/%s.st%d", Model3->GetGameInfo()->id, s_saveSlot);
++ char filePath[512];
++ sprintf(filePath, "%s/.supermodel/saves/%s.st%d", getenv("HOME"), Model3->GetGameInfo()->id, s_saveSlot);
+ if (OKAY != SaveState.Create(filePath, "Supermodel Save State", "Supermodel Version " SUPERMODEL_VERSION))
+ {
+ ErrorLog("Unable to save state to '%s'.", filePath);
@@ -744,8 +748,8 @@
- CBlockFile SaveState;
-
- // Generate file path
-- char filePath[24];
-- sprintf(filePath, "Saves/%s.st%d", Model3->GetGameInfo()->id, s_saveSlot);
-+ char filePath[512];
-+ sprintf(filePath, "%s/.supermodel/saves/%s.st%d", getenv("HOME"), Model3->GetGameInfo()->id, s_saveSlot);
-
- // Open and check to make sure format is correct
- if (OKAY != SaveState.Load(filePath))
+ CBlockFile SaveState;
+
+ // Generate file path
+- char filePath[24];
+- sprintf(filePath, "Saves/%s.st%d", Model3->GetGameInfo()->id, s_saveSlot);
++ char filePath[512];
++ sprintf(filePath, "%s/.supermodel/saves/%s.st%d", getenv("HOME"), Model3->GetGameInfo()->id, s_saveSlot);
+
+ // Open and check to make sure format is correct
+ if (OKAY != SaveState.Load(filePath))
@@ -779,8 +783,8 @@
- {
- CBlockFile NVRAM;
-
-- char filePath[24];
-- sprintf(filePath, "NVRAM/%s.nv", Model3->GetGameInfo()->id);
-+ char filePath[512];
-+ sprintf(filePath, "%s/.supermodel/NVRAM/%s.nv", getenv("HOME"), Model3->GetGameInfo()->id);
- if (OKAY != NVRAM.Create(filePath, "Supermodel NVRAM State", "Supermodel Version " SUPERMODEL_VERSION))
- {
- ErrorLog("Unable to save NVRAM to '%s'. Make sure directory exists!", filePath);
+ {
+ CBlockFile NVRAM;
+
+- char filePath[24];
+- sprintf(filePath, "NVRAM/%s.nv", Model3->GetGameInfo()->id);
++ char filePath[512];
++ sprintf(filePath, "%s/.supermodel/NVRAM/%s.nv", getenv("HOME"), Model3->GetGameInfo()->id);
+ if (OKAY != NVRAM.Create(filePath, "Supermodel NVRAM State", "Supermodel Version " SUPERMODEL_VERSION))
+ {
+ ErrorLog("Unable to save NVRAM to '%s'. Make sure directory exists!", filePath);
@@ -803,8 +807,8 @@
- CBlockFile NVRAM;
-
- // Generate file path
-- char filePath[24];
-- sprintf(filePath, "NVRAM/%s.nv", Model3->GetGameInfo()->id);
-+ char filePath[512];
-+ sprintf(filePath, "%s/.supermodel/NVRAM/%s.nv", getenv("HOME"), Model3->GetGameInfo()->id);
-
- // Open and check to make sure format is correct
- if (OKAY != NVRAM.Load(filePath))
+ CBlockFile NVRAM;
+
+ // Generate file path
+- char filePath[24];
+- sprintf(filePath, "NVRAM/%s.nv", Model3->GetGameInfo()->id);
++ char filePath[512];
++ sprintf(filePath, "%s/.supermodel/NVRAM/%s.nv", getenv("HOME"), Model3->GetGameInfo()->id);
+
+ // Open and check to make sure format is correct
+ if (OKAY != NVRAM.Load(filePath))