summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsekret2017-09-24 11:04:02 +0200
committersekret2017-09-24 11:04:02 +0200
commit7828f982b45efe2603cc5aacca47e5b04f8e611a (patch)
treee776162c476f6a93889a55ddc4c3f7fed03100eb
downloadaur-7828f982b45efe2603cc5aacca47e5b04f8e611a.tar.gz
initial release
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d974b1b3c01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Sep 24 09:04:02 UTC 2017
+pkgbase = plotbitrate-git
+ pkgdesc = a script for plotting the bitrate of an audio or video stream over time
+ pkgver = 0.r13.f93131f
+ pkgrel = 1
+ url = https://github.com/zeroepoch/plotbitrate
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = python-matplotlib
+ depends = ffmpeg
+ provides = plotbitrate
+ conflicts = plotbitrate
+ source = plotbitrate::git+https://github.com/zeroepoch/plotbitrate.git
+ md5sums = SKIP
+
+pkgname = plotbitrate-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99c6ecec8b33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
+
+_pkgname=plotbitrate
+pkgname=$_pkgname-git
+pkgver=0.r13.f93131f
+pkgrel=1
+pkgdesc="a script for plotting the bitrate of an audio or video stream over time"
+arch=('any')
+url="https://github.com/zeroepoch/plotbitrate"
+license=('BSD')
+depends=('python-matplotlib' 'ffmpeg')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm755 "$_pkgname.py" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: