summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2019-11-26 21:31:49 +0300
committerViktor Drobot2019-11-26 21:31:49 +0300
commit78476e6675cd7a5d3f450d27791e77c44b7b4b4c (patch)
treeccb943caffe4c3c7da4a2433d3e325cda258bfe0
parentea14633658203d66f0dd15caa7a121fddafe9165 (diff)
downloadaur-78476e6675cd7a5d3f450d27791e77c44b7b4b4c.tar.gz
Update to latest version
-rw-r--r--.SRCINFO42
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD112
3 files changed, 55 insertions, 107 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d97a108b90c..fc604ba51441 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,42 +1,30 @@
pkgbase = shiboken2-git
- pkgver = 5.12.2.r6266.54f48761
+ pkgdesc = Generates bindings for C++ libraries using CPython source code
+ pkgver = r6554.6eb583d7
pkgrel = 1
- url = http://www.pyside.org
- arch = i686
+ url = https://www.qt.io
arch = x86_64
+ license = GPL2
license = LGPL
- makedepends = git
- makedepends = llvm
makedepends = clang
+ makedepends = llvm
makedepends = cmake
- makedepends = python2
- makedepends = python
makedepends = libxslt
makedepends = qt5-xmlpatterns
- source = shiboken2-git::git+https://code.qt.io/pyside/pyside-setup.git#branch=5.12
+ makedepends = python-sphinx
+ source = shiboken2-git::git+https://code.qt.io/pyside/pyside-setup.git
sha256sums = SKIP
-pkgname = python2-shiboken2-git
- pkgdesc = Support library for Python2 bindings
- depends = python2
- depends = shiboken2-git
- provides = python2-shiboken2=5.12.2
- conflicts = python2-shiboken2
-
-pkgname = python-shiboken2-git
- pkgdesc = Support library for Python bindings
- depends = python
- depends = shiboken2-git
- provides = python-shiboken2=5.12.2
- conflicts = python-shiboken2
-
pkgname = shiboken2-git
- pkgdesc = CPython bindings generator for C++ libraries
+ depends = clang=9.0.0
+ depends = llvm
depends = libxslt
- depends = clang
depends = qt5-xmlpatterns
- optdepends = python2-shiboken2-git: for compilation against python2
- optdepends = python-shiboken2-git: for compilation against python
- provides = shiboken2=5.12.2
+ provides = shiboken2
conflicts = shiboken2
+pkgname = python-shiboken2-git
+ depends = python
+ provides = python-shiboken2
+ conflicts = python-shiboken2
+
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index eeaf99a61cea..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,8 +0,0 @@
-*
-!.gitignore
-!PKGBUILD
-!.SRCINFO
-!*.install
-!ChangeLog
-!*.diff
-!*.patch
diff --git a/PKGBUILD b/PKGBUILD
index e1971d822519..a6e2ad620fe0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Cebtenzzre <cebtenzzre (at) gmail (dot) com>
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Cebtenzzre <cebtenzzre (at) gmail (dot) com>
# Contributor: Markus Hovorka <m.hovorka@live.de>
# Contributor: Florian Pritz <bluewind@xinu.at>
# Contributor: Jelle van der Waa <jelle@vdwaa.nl>
@@ -6,92 +7,59 @@
# Contributor: Matthias Maennich <arch@maennich.net>
pkgbase=shiboken2-git
-pkgname=(python{2,}-shiboken2-git shiboken2-git)
-pkgver=5.12.2.r6266.54f48761
+pkgname=(shiboken2-git python-shiboken2-git)
+_clangver=9.0.0
+pkgver=r6554.6eb583d7
pkgrel=1
-arch=('i686' 'x86_64')
-license=('LGPL')
-url="http://www.pyside.org"
-makedepends=('git' 'llvm' 'clang' 'cmake' 'python2' 'python' 'libxslt'
- 'qt5-xmlpatterns')
-source=("$pkgbase::git+https://code.qt.io/pyside/pyside-setup.git#branch=5.12")
+arch=(x86_64)
+url='https://www.qt.io'
+license=(GPL2 LGPL)
+pkgdesc='Generates bindings for C++ libraries using CPython source code'
+makedepends=(clang llvm cmake libxslt qt5-xmlpatterns python-sphinx)
+source=("$pkgbase::git+https://code.qt.io/pyside/pyside-setup.git")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgbase"
- _upver="$(python sources/shiboken2/shiboken_version.py | cut -d';' -f-3 | tr ';' '.')"
- printf "%s.r%s.%s" "$_upver" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
-build() {
- # Build for python2.
- cd "$srcdir"/$pkgbase/sources/shiboken2
- cmake_args="-DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DBUILD_TESTS=OFF -DCMAKE_CXX_COMPILER=/usr/bin/clang++"
- mkdir -p build-py2 && cd build-py2
- cmake \
- -DUSE_PYTHON_VERSION=2 \
- ${cmake_args} ..
- make
+ cd "${srcdir}/${pkgname}"
- # Build for python3.
- cd "$srcdir"/$pkgbase/sources/shiboken2
- mkdir -p build-py3 && cd build-py3
- cmake \
- -DUSE_PYTHON_VERSION=3 \
- ${cmake_args} ..
- make
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-package_shiboken2-git() {
- pkgdesc="CPython bindings generator for C++ libraries"
- depends=('libxslt' 'clang' 'qt5-xmlpatterns')
- optdepends=("python2-shiboken2-git: for compilation against python2"
- "python-shiboken2-git: for compilation against python")
- provides=("shiboken2=${pkgver%%.r*}")
- conflicts=("shiboken2")
-
- cd "$srcdir"/$pkgbase/sources/shiboken2/build-py3
- make DESTDIR="$pkgdir" install
+prepare() {
+ cd "${srcdir}/${pkgbase}"
- _upver="${pkgver%%.r*}"
- rm -rf "$pkgdir/usr/lib/python"*
- rm -rf "$pkgdir/usr/lib/libshiboken2"*
- rm -rf "$pkgdir/usr/lib/pkgconfig/"
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}"/Shiboken2Config*python*.cmake
+ mkdir -p build
+ sed -e 's|0307FFFF|0308FFFF|' -i sources/shiboken2/libshiboken/pep384impl.h # Support python 3.8
}
-package_python2-shiboken2-git() {
- pkgdesc="Support library for Python2 bindings"
- depends=("python2" "shiboken2-git")
- provides=("python2-shiboken2=${pkgver%%.r*}")
- conflicts=("python2-shiboken2")
+build() {
+ cd "${srcdir}/${pkgbase}/build"
- cd "$srcdir"/$pkgbase/sources/shiboken2/build-py2
- make DESTDIR="$pkgdir" install
+ cmake ../sources/shiboken2 \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_TESTS=OFF \
+ -DUSE_PYTHON_VERSION=3
+ make
+}
- mv "$pkgdir"/usr/lib/pkgconfig/shiboken2{,-py2}.pc
+package_shiboken2-git() {
+ depends=(clang=$_clangver llvm libxslt qt5-xmlpatterns)
+ conflicts=(shiboken2)
+ provides=(shiboken2)
- _upver="${pkgver%%.r*}"
- rm -rf "$pkgdir"/usr/{include,bin,share}
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}/Shiboken2ConfigVersion.cmake"
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}/Shiboken2Config.cmake"
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}"/Shiboken2Targets{,-release}.cmake
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}/shiboken_helpers.cmake"
+ cd "${srcdir}/${pkgbase}/build"
+ make DESTDIR="$pkgdir" install
+# Provided in python-shiboken2
+ rm -r "$pkgdir"/usr/lib/{python*,libshiboken*}
}
package_python-shiboken2-git() {
- pkgdesc="Support library for Python bindings"
- depends=("python" "shiboken2-git")
- provides=("python-shiboken2=${pkgver%%.r*}")
- conflicts=("python-shiboken2")
-
- cd "$srcdir"/$pkgbase/sources/shiboken2/build-py3
- make DESTDIR="$pkgdir" install
+ depends=(python)
+ conflicts=(python-shiboken2)
+ provides=(python-shiboken2)
- _upver="${pkgver%%.r*}"
- rm -rf "$pkgdir"/usr/{include,bin,share}
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}/Shiboken2ConfigVersion.cmake"
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}/Shiboken2Config.cmake"
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}"/Shiboken2Targets{,-release}.cmake
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}/shiboken_helpers.cmake"
+ cd "${srcdir}/${pkgbase}/build"
+ make DESTDIR="$pkgdir" install
+# Provided in shiboken2
+ rm -r "$pkgdir"/usr/{bin,include,lib/{cmake,pkgconfig},share}
}