summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephanie Wilde-Hobbs2020-11-10 16:43:24 +0000
committerStephanie Wilde-Hobbs2020-11-10 16:43:24 +0000
commit78486bec0226b0e938c5c7dc24bb8a970d532b76 (patch)
treeb8d5a070f6b5b8c663ea8d71b10285ec742802b7
parent7f6db3fae42afd13f2eda462f6d0ca4b00dd197c (diff)
downloadaur-78486bec0226b0e938c5c7dc24bb8a970d532b76.tar.gz
Update gnupg-git package
-rw-r--r--PKGBUILD75
-rw-r--r--drop-import-clean.patch52
-rw-r--r--gnupg-git.install12
3 files changed, 95 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f1fcd8bc2e0..c1c680985977 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,52 @@
-# GnuPG2 GIT version
+# Maintainer: Stephanie Wilde-Hobbs <git@stephanie.is>
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
# Contributor: Lex Black <autumn-wind at web dot de>
# Contributor: alphazo@gmail.com
-# Based on official package
-# Cleanup from @holos
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+# Contributor: @holos
-_gitname=gnupg
-pkgname=gnupg-git
-pkgver=2.2.0+12+g9f5e50e7c
-pkgrel=2
-pkgdesc='Complete and free implementation of the OpenPGP standard - development'
-url="http://www.gnupg.org/"
+_pkgname=gnupg
+pkgname=${_pkgname}-git
+pkgver=2.2.7+1227+gf9bbc7516
+pkgrel=1
+pkgdesc='Complete and free implementation of the OpenPGP standard'
+url='https://www.gnupg.org/'
license=('GPL')
-arch=('i686' 'x86_64')
-optdepends=('libldap: gpg2keys_ldap'
- 'libusb-compat: scdaemon')
-makedepends=('git' 'libldap' 'libusb-compat')
+arch=('x86_64')
+conflicts=(${_pkgname})
+provides=(${_pkgname}=2.2)
checkdepends=('openssh')
-depends=('npth-git' 'libgpg-error' 'libgcrypt-git' 'libksba' 'libassuan-git'
- 'pinentry' 'bzip2' 'readline' 'gnutls' 'sqlite')
-provides=("gnupg=${pkgver}" 'dirmngr')
-conflicts=('gnupg2' 'gnupg' 'dirmngr')
-install=${pkgname}.install
-source=("git://git.gnupg.org/gnupg.git")
-sha1sums=('SKIP')
+makedepends=('libldap' 'libusb-compat' 'pcsclite' 'git' 'fig2dev' 'imagemagick' 'librsvg')
+depends=('npth' 'libgpg-error' 'libgcrypt' 'libksba' 'libassuan'
+ 'pinentry' 'bzip2' 'readline' 'libreadline.so' 'gnutls'
+ 'sqlite' 'zlib' 'glibc')
+optdepends=('libldap: gpg2keys_ldap'
+ 'libusb-compat: scdaemon'
+ 'pcsclite: scdaemon')
+source=("git://git.gnupg.org/gnupg.git"
+ 'drop-import-clean.patch')
+sha256sums=('SKIP'
+ '7ae777b0f4c6d3301768149f66f1d5b723841f3a4a2f0d4c601a0b2114bb7fe1')
+install=gnupg-git.install
pkgver() {
- cd "$_gitname"
+ cd "${srcdir}/${_pkgname}"
git describe --tags | sed 's/gnupg-//;s/-/+/g'
}
prepare() {
- cd "${_gitname}"
+ cd "${srcdir}/${_pkgname}"
+ patch -p1 -i ../drop-import-clean.patch
+
./autogen.sh
- sed '/noinst_SCRIPTS = gpg-zip/c sbin_SCRIPTS += gpg-zip' -i tools/Makefile.in
}
build() {
- cd "${_gitname}"
+ cd "${srcdir}/${_pkgname}"
./configure \
--prefix=/usr \
--sysconfdir=/etc \
@@ -48,19 +58,18 @@ build() {
make
}
-check() {
- cd "${_gitname}"
- make check
-}
+# check() {
+# cd "${srcdir}/${_pkgname}"
+# make check
+# }
package() {
- cd "${_gitname}"
+ cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}" install
ln -s gpg "${pkgdir}"/usr/bin/gpg2
ln -s gpgv "${pkgdir}"/usr/bin/gpgv2
- cd doc/examples/systemd-user
- for i in *.*; do
- install -Dm644 "$i" "${pkgdir}/usr/lib/systemd/user/$i"
- done
+ install -Dm 644 doc/examples/systemd-user/*.* -t "${pkgdir}/usr/lib/systemd/user"
}
+
+# vim: ts=2 sw=2 noet:
diff --git a/drop-import-clean.patch b/drop-import-clean.patch
new file mode 100644
index 000000000000..9c42fece93ad
--- /dev/null
+++ b/drop-import-clean.patch
@@ -0,0 +1,52 @@
+From 1690a464b28fa24ce82189a9bf5d7ce9b44804b8 Mon Sep 17 00:00:00 2001
+From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
+Date: Mon, 15 Jul 2019 16:24:35 -0400
+Subject: [PATCH 3/7] gpg: drop import-clean from default keyserver import
+ options
+
+* g10/gpg.c (main): drop IMPORT_CLEAN from the
+default opt.keyserver_options.import_options
+* doc/gpg.texi: reflect this change in the documentation
+
+Given that SELF_SIGS_ONLY is already set, it's not clear what
+additional benefit IMPORT_CLEAN provides. Furthermore, IMPORT_CLEAN
+means that receiving an OpenPGP certificate from a keyserver will
+potentially delete data that is otherwise held in the local keyring,
+which is surprising to users who expect retrieval from the keyservers
+to be purely additive.
+
+GnuPG-Bug-Id: 4628
+Signed-off-by: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
+---
+ doc/gpg.texi | 2 +-
+ g10/gpg.c | 3 +--
+ 2 files changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/doc/gpg.texi b/doc/gpg.texi
+index 4870441d4..551459a74 100644
+--- a/doc/gpg.texi
++++ b/doc/gpg.texi
+@@ -1963,7 +1963,7 @@ are available for all keyserver types, some common options are:
+
+ @end table
+
+-The default list of options is: "self-sigs-only, import-clean,
++The default list of options is: "self-sigs-only,
+ repair-keys, repair-pks-subkey-bug, export-attributes,
+ honor-pka-record".
+
+diff --git a/g10/gpg.c b/g10/gpg.c
+index 68cc22041..fa2bcfa5e 100644
+--- a/g10/gpg.c
++++ b/g10/gpg.c
+@@ -2407,6 +2407,5 @@ main (int argc, char **argv)
+ | IMPORT_SELF_SIGS_ONLY
+ | IMPORT_COLLAPSE_UIDS
+- | IMPORT_COLLAPSE_SUBKEYS
+- | IMPORT_CLEAN);
++ | IMPORT_COLLAPSE_SUBKEYS);
+ opt.keyserver_options.export_options = EXPORT_ATTRIBUTES;
+ opt.keyserver_options.options = KEYSERVER_HONOR_PKA_RECORD;
+--
+2.27.0
+
diff --git a/gnupg-git.install b/gnupg-git.install
index b3032247f442..1f19b99feb2d 100644
--- a/gnupg-git.install
+++ b/gnupg-git.install
@@ -26,16 +26,6 @@ post_install() {
_global_units enable
}
-post_upgrade() {
- if (( $(vercmp $2 2.1.13-1) < 0 )); then
- echo "==> Please kill running gpg-agent and dirmngr processes before using this release."
- fi
-
- if (( $(vercmp $2 2.1.21-3) < 0 )); then
- _global_units enable
- fi
-}
-
pre_remove() {
_global_units disable
-} \ No newline at end of file
+}