summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Mazieres2016-03-03 10:30:09 -0800
committerDavid Mazieres2016-03-03 10:30:09 -0800
commit78a0cc19b6a257171bb01495467b5444dbc592a2 (patch)
treea944b8d2961cc66e46bd9139faabb18e434af05f
downloadaur-78a0cc19b6a257171bb01495467b5444dbc592a2.tar.gz
Initial package for stellar-core-git.
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD55
2 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ab39e1e78d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Thu Mar 3 18:27:06 UTC 2016
+pkgbase = stellar-core-git
+ pkgdesc = core daemon for backbone nodes in the payment Stellar network
+ pkgver = v0.4.1.61.gffd1ccd
+ pkgrel = 1
+ url = https://www.stellar.org/
+ arch = x86_64
+ arch = i686
+ license = APACHE
+ makedepends = git
+ depends = postgresql
+ provides = stellar-core
+ conflicts = stellar-core
+ source = git+https://github.com/stellar/stellar-core.git
+ source = libmedida::git+https://github.com/stellar/medida.git
+ source = git+https://github.com/stellar/libsodium.git
+ source = git+https://github.com/xdrpp/xdrpp.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = stellar-core-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef618134a781
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+
+# Maintainer: David Mazieres (http://www.scs.stanford.edu/~dm/addr/)
+pkgname=stellar-core-git
+pkgver=0
+pkgrel=1
+pkgdesc="core daemon for backbone nodes in the payment Stellar network"
+arch=(x86_64 i686)
+url="https://www.stellar.org/"
+license=('APACHE')
+depends=(postgresql)
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=
+source=('git+https://github.com/stellar/stellar-core.git'
+ 'libmedida::git+https://github.com/stellar/medida.git'
+ 'git+https://github.com/stellar/libsodium.git'
+ 'git+https://github.com/xdrpp/xdrpp.git'
+ )
+noextract=()
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --always --dirty --tags | sed -e 's/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ git submodule init
+
+ for dir in $(git config -f .gitmodules --list \
+ | sed -ne 's/[^=]*\.path=//p'); do
+ echo git config "submodule.$dir.url" "$srcdir/$(basename $dir)"
+ git config "submodule.$dir.url" "$srcdir/$(basename $dir)"
+ done
+
+ ./autogen.sh
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/${pkgname%-git}"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}