summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Mulford2019-07-16 21:13:33 -0700
committerDaniel Mulford2019-07-16 21:13:33 -0700
commit78a71ae714d41d3cfb44d4b081fc84a8b456ce48 (patch)
tree1a4935535375eaf09f5a30076d6fbd4104683024
downloadaur-78a71ae714d41d3cfb44d4b081fc84a8b456ce48.tar.gz
Initial commit; patch script with shebang and install in /usr/bin with execute privileges
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
-rw-r--r--wavdumper-0.5.patch8
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d808a29f0e16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = wavdumper
+ pkgdesc = Print detailed information on the headers and structure of a WAV file.
+ pkgver = 0.5
+ pkgrel = 1
+ url = https://www.cs.helsinki.fi/u/hkovaska/wavdumper/
+ arch = any
+ license = GPL2
+ depends = python2
+ source = https://www.cs.helsinki.fi/u/hkovaska/wavdumper/wavdumper-0.5.tar.gz
+ source = wavdumper-0.5.patch
+ md5sums = c5a079bc68c7bdd205fc5bb69b380176
+ md5sums = 054bbb824051eef16a529fa4ed13fd86
+
+pkgname = wavdumper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9cb1cc3e848
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Daniel Mulford <dgmulf@gmail.com>
+pkgname=wavdumper
+pkgver=0.5
+pkgrel=1
+pkgdesc="Print detailed information on the headers and structure of a WAV file."
+arch=('any')
+url="https://www.cs.helsinki.fi/u/hkovaska/wavdumper/"
+license=('GPL2')
+depends=('python2')
+source=("https://www.cs.helsinki.fi/u/hkovaska/wavdumper/wavdumper-0.5.tar.gz"
+ "$pkgname-$pkgver.patch")
+md5sums=('c5a079bc68c7bdd205fc5bb69b380176'
+ '054bbb824051eef16a529fa4ed13fd86')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -i "$srcdir/$pkgname-$pkgver.patch"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ mkdir -p "$pkgdir/usr/bin"
+ cp wavdumper.py "$pkgdir/usr/bin/wavdumper"
+ chmod a+x "$pkgdir/usr/bin/wavdumper"
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname"
+ cp readme.html "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/wavdumper-0.5.patch b/wavdumper-0.5.patch
new file mode 100644
index 000000000000..8304d25d2001
--- /dev/null
+++ b/wavdumper-0.5.patch
@@ -0,0 +1,8 @@
+--- wavdumper.py 2004-01-26 11:25:32.000000000 -0800
++++ /dev/fd/63 2019-07-16 18:13:53.976140483 -0700
+@@ -1,3 +1,5 @@
++#!/usr/bin/env python2
++
+ import glob
+ import math
+ import os