summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas ANDREJAK2018-05-26 11:59:00 +0200
committerThomas ANDREJAK2018-05-26 11:59:00 +0200
commit78ba5ba0e30a7e103bc8a014beae0c468c90ce37 (patch)
tree0227a737f73bf31af70bc152036f119866071314
parent3cffa6cd1edf2310efc02db847cb8962eb0d3c30 (diff)
downloadaur-78ba5ba0e30a7e103bc8a014beae0c468c90ce37.tar.gz
Update to 4.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--libprelude-4.1.0-fix_compatibility_gnutls_3_6.patch20
3 files changed, 34 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6510b01e35c..8d638764edf3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libprelude
pkgdesc = Provides the framework for using the Prelude system
- pkgver = 4.0.0
+ pkgver = 4.1.0
pkgrel = 1
url = https://www.prelude-siem.org
arch = i686
@@ -16,8 +16,10 @@ pkgbase = libprelude
backup = etc/prelude/default/global.conf
backup = etc/prelude/default/idmef-client.conf
backup = etc/prelude/default/tls.conf
- source = https://www.prelude-siem.org/pkg/src/4.0.0/libprelude-4.0.0.tar.gz
- md5sums = f4bd0ece58245797db14c971133536a2
+ source = https://www.prelude-siem.org/pkg/src/4.1.0/libprelude-4.1.0.tar.gz
+ source = libprelude-4.1.0-fix_compatibility_gnutls_3_6.patch
+ md5sums = d75977db58de9ba4cf9c4d00a0e25cb9
+ md5sums = 5237abe04d26bc071b1018d456550259
pkgname = libprelude
diff --git a/PKGBUILD b/PKGBUILD
index cbf5ed45542f..bcfa825aea51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Thomas Andrejak <thomas.andrejak@gmail.com>
pkgname=libprelude
-pkgver=4.0.0
+pkgver=4.1.0
pkgrel=1
pkgdesc="Provides the framework for using the Prelude system"
arch=('i686' 'x86_64')
@@ -13,8 +13,9 @@ depends=('gnutls' 'python2' 'python3' 'gtk-doc' 'lua' 'ruby')
backup=('etc/prelude/default/client.conf'
'etc/prelude/default/global.conf'
'etc/prelude/default/idmef-client.conf'
- 'etc/prelude/default/tls.conf')
-source=("https://www.prelude-siem.org/pkg/src/4.0.0/$pkgname-$pkgver.tar.gz")
+ 'etc/prelude/default/tls.conf')
+source=("https://www.prelude-siem.org/pkg/src/4.1.0/$pkgname-$pkgver.tar.gz"
+ "libprelude-4.1.0-fix_compatibility_gnutls_3_6.patch")
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -27,4 +28,8 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums=('f4bd0ece58245797db14c971133536a2')
+prepare() {
+ patch -p0 <libprelude-4.1.0-fix_compatibility_gnutls_3_6.patch
+}
+
+md5sums=('d75977db58de9ba4cf9c4d00a0e25cb9' '5237abe04d26bc071b1018d456550259')
diff --git a/libprelude-4.1.0-fix_compatibility_gnutls_3_6.patch b/libprelude-4.1.0-fix_compatibility_gnutls_3_6.patch
new file mode 100644
index 000000000000..4fd60a9e143e
--- /dev/null
+++ b/libprelude-4.1.0-fix_compatibility_gnutls_3_6.patch
@@ -0,0 +1,20 @@
+--- libprelude-4.1.0/prelude-admin/tls-register.c 2017-07-17 12:03:05.762000000 +0200
++++ libprelude-4.1.0/prelude-admin/tls-register.c2 2017-10-09 09:37:26.874129389 +0200
+@@ -409,7 +409,7 @@
+ goto err;
+ }
+
+- ret = gnutls_x509_crt_sign(crt, ca_crt, ca_key);
++ ret = gnutls_x509_crt_sign2(crt, ca_crt, ca_key, GNUTLS_DIG_SHA256, 0);
+ if ( ret < 0 ) {
+ fprintf(stderr, "error signing certificate: %s.\n", gnutls_strerror(ret));
+ goto err;
+@@ -445,7 +445,7 @@
+ gnutls_x509_crt_set_ca_status(crt, 1);
+ gnutls_x509_crt_set_key_usage(crt, usage);
+
+- ret = gnutls_x509_crt_sign(crt, crt, key);
++ ret = gnutls_x509_crt_sign2(crt, crt, key, GNUTLS_DIG_SHA256, 0);
+ if ( ret < 0 ) {
+ fprintf(stderr, "error self-signing certificate: %s.\n", gnutls_strerror(ret));
+ gnutls_x509_crt_deinit(crt);