summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2022-01-05 21:10:43 +0100
committerJan Cholasta2022-01-05 21:10:43 +0100
commit78c152e6e92eebae14f90399290ca80569308056 (patch)
tree53f8f869db6dd30317b9626deea90bb3874513af
parent2bf4a14ffd127bdcd952549327c7e60ef74dd811 (diff)
downloadaur-78c152e6e92eebae14f90399290ca80569308056.tar.gz
gzdoom-git-4.8pre+105+ge6403197e-1
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-file-paths.patch10
-rw-r--r--PKGBUILD5
3 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c41db6cb63d8..7c2686fc896b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gzdoom-git
pkgdesc = Feature centric port for all Doom engine games (git version)
- pkgver = 4.7.0pre+138+gff497996a
+ pkgver = 4.8pre+105+ge6403197e
pkgrel = 1
url = http://www.zdoom.org/
arch = i686
@@ -43,7 +43,7 @@ pkgbase = gzdoom-git
source = 0001-Fix-file-paths.patch
sha256sums = SKIP
sha256sums = 59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d
- sha256sums = 7db3c08eb3756a19a9b6eda76f169e82e8c47b9a28108f17aac24774e2e53ff1
+ sha256sums = 195a9d1ec0489bd38f1d6c40763e66773dd74f5f719acb6afa32a077fdb0b8f4
optdepends_x86_64 = vulkan-driver: Vulkan renderer
optdepends_x86_64 = vulkan-icd-loader: Vulkan renderer
diff --git a/0001-Fix-file-paths.patch b/0001-Fix-file-paths.patch
index d8356f6f080d..cc8adb641d4a 100644
--- a/0001-Fix-file-paths.patch
+++ b/0001-Fix-file-paths.patch
@@ -1,4 +1,4 @@
-From 4daa1663a0fe0fb0cbf416ee064e0382bd5d5bda Mon Sep 17 00:00:00 2001
+From 99e82d0644fee9a21e967b7b8708ff253e7528d5 Mon Sep 17 00:00:00 2001
From: Jan Cholasta <jan@cholasta.net>
Date: Tue, 25 Feb 2020 12:53:07 +0100
Subject: [PATCH] Fix file paths
@@ -9,7 +9,7 @@ Subject: [PATCH] Fix file paths
2 files changed, 3 insertions(+), 21 deletions(-)
diff --git a/src/common/platform/posix/sdl/i_main.cpp b/src/common/platform/posix/sdl/i_main.cpp
-index b52561fdf..7260dab91 100644
+index a28b90f01..7299029fd 100644
--- a/src/common/platform/posix/sdl/i_main.cpp
+++ b/src/common/platform/posix/sdl/i_main.cpp
@@ -175,19 +175,7 @@ int main (int argc, char **argv)
@@ -30,11 +30,11 @@ index b52561fdf..7260dab91 100644
- progdir = "./";
- }
+ progdir = "/usr/lib/gzdoom/";
-
+
I_StartupJoysticks();
diff --git a/src/gameconfigfile.cpp b/src/gameconfigfile.cpp
-index 830cef232..2b49b26d9 100644
+index 17898f3ae..7bfb63205 100644
--- a/src/gameconfigfile.cpp
+++ b/src/gameconfigfile.cpp
@@ -119,8 +119,6 @@ FGameConfigFile::FGameConfigFile ()
@@ -69,5 +69,5 @@ index 830cef232..2b49b26d9 100644
SetValueForKey("Path", "/usr/share/doom/fm_banks", true);
SetValueForKey("Path", "/usr/share/games/doom/soundfonts", true);
--
-2.32.0
+2.34.1
diff --git a/PKGBUILD b/PKGBUILD
index 6cae896e36b3..7ffaabbeb883 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
pkgname=gzdoom-git
-pkgver=4.7.0pre+138+gff497996a
+pkgver=4.8pre+105+ge6403197e
pkgrel=1
pkgdesc='Feature centric port for all Doom engine games (git version)'
arch=('i686' 'x86_64')
@@ -41,7 +41,7 @@ source=('gzdoom::git://github.com/coelckers/gzdoom.git'
'0001-Fix-file-paths.patch')
sha256sums=('SKIP'
'59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d'
- '7db3c08eb3756a19a9b6eda76f169e82e8c47b9a28108f17aac24774e2e53ff1')
+ '195a9d1ec0489bd38f1d6c40763e66773dd74f5f719acb6afa32a077fdb0b8f4')
pkgver() {
cd gzdoom
@@ -50,7 +50,6 @@ pkgver() {
prepare() {
cd gzdoom
- git submodule update --init
patch -i "$srcdir"/0001-Fix-file-paths.patch -p 1
}