summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorabrer2019-05-24 13:23:15 -0400
committerabrer2019-05-24 13:23:15 -0400
commit78c5baa66645598e54f2d9c804d6d5537363e8e0 (patch)
tree3279e357b65aabf5160c8fcb802af9f490c0d090
downloadaur-78c5baa66645598e54f2d9c804d6d5537363e8e0.tar.gz
Initial submission.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b319a401ebdf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dkoch-git
+ pkgdesc = A program for learning morse code using the Koch and/or Farnsworth methods.
+ pkgver = 8.10ba713
+ pkgrel = 1
+ url = https://gitlab.com/big-friendian/dkoch
+ arch = any
+ license = MIT
+ depends = dmd
+ depends = dub
+ depends = sdl
+ source = dkoch-git::git+https://gitlab.com/big-friendian/dkoch.git
+ md5sums = SKIP
+
+pkgname = dkoch-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0397ebaf63a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Abrer <ahbrer@gmail.com>
+
+pkgname='dkoch-git'
+pkgver=8.10ba713
+pkgrel=1
+arch=('any')
+url="https://gitlab.com/big-friendian/dkoch"
+license=('MIT')
+pkgdesc="A program for learning morse code using the Koch and/or Farnsworth methods."
+depends=( "dmd"
+ "dub"
+ "sdl2" )
+source=("$pkgname"::'git+https://gitlab.com/big-friendian/dkoch.git')
+
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$pkgname"
+ dub build --build=release
+}
+
+package() {
+ cd "$pkgname"
+ mkdir -p $pkgdir/usr/bin/
+ cp dkoch $pkgdir/usr/bin/
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}