summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2020-12-27 10:57:33 +0100
committerNicola Murino2020-12-27 10:57:33 +0100
commit78fe5aea7a5be6f26094c44ee26e20473f805e12 (patch)
treee4188e73d7d839263fea7a71c13646c10a99f58d
parent9903a723efc0df380beee21735f2304fd13d3f62 (diff)
downloadaur-78fe5aea7a5be6f26094c44ee26e20473f805e12.tar.gz
update to 1.18.2
-rw-r--r--.SRCINFO6
-rw-r--r--4.5.0.patch25
-rw-r--r--PKGBUILD15
3 files changed, 6 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e4a11769da6..9bcbe1e9b902 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gst-plugins-opencv
pkgdesc = GStreamer open-source multimedia framework OpenCV plugins
- pkgver = 1.18.1
+ pkgver = 1.18.2
pkgrel = 1
url = https://gstreamer.freedesktop.org/
arch = x86_64
@@ -9,10 +9,8 @@ pkgbase = gst-plugins-opencv
makedepends = git
depends = gst-plugins-base-libs
depends = opencv
- source = git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=e5c3c106a2da607953fea36e3a253b382c939684
- source = 4.5.0.patch
+ source = git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=b375ee4cdbcb98687c226d6564f8678a809cf02a
sha256sums = SKIP
- sha256sums = 59c4401641d619f6ca0fffd853dad0a2e027d3aba1698c81d5017a23e6ac6ff4
pkgname = gst-plugins-opencv
diff --git a/4.5.0.patch b/4.5.0.patch
deleted file mode 100644
index af21cce4a123..000000000000
--- a/4.5.0.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From ae821f523e34b77135f865011266ed7d6540ba1c Mon Sep 17 00:00:00 2001
-From: Nicola Murino <nicola.murino@gmail.com>
-Date: Sun, 18 Oct 2020 17:59:44 +0200
-Subject: [PATCH] opencv: allow compilation against 4.5.x
-
----
- ext/opencv/meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build
-index 074272a9c..e3d1865da 100644
---- a/ext/opencv/meson.build
-+++ b/ext/opencv/meson.build
-@@ -66,7 +66,7 @@ if opencv_found
- endif
- endforeach
- else
-- opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.5.0'], required : false)
-+ opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.6.0'], required : false)
- opencv_found = opencv_dep.found()
- if opencv_found
- foreach h : libopencv4_headers
---
-2.28.0
-
diff --git a/PKGBUILD b/PKGBUILD
index b59e4b211e79..1f11621d422e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=gst-plugins-opencv
_pkgname=gst-plugins-bad
-pkgver=1.18.1
+pkgver=1.18.2
pkgrel=1
pkgdesc="GStreamer open-source multimedia framework OpenCV plugins"
url="https://gstreamer.freedesktop.org/"
@@ -9,22 +9,15 @@ arch=(x86_64)
license=(LGPL)
depends=(gst-plugins-base-libs opencv)
makedepends=(meson git)
-_commit=e5c3c106a2da607953fea36e3a253b382c939684 # tags/1.18.1^0
-source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=$_commit"
- "4.5.0.patch")
-sha256sums=('SKIP'
- '59c4401641d619f6ca0fffd853dad0a2e027d3aba1698c81d5017a23e6ac6ff4')
+_commit=b375ee4cdbcb98687c226d6564f8678a809cf02a # tags/1.18.2^0
+source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=$_commit")
+sha256sums=('SKIP')
pkgver() {
cd $_pkgname
git describe --tags | sed 's/-/+/g'
}
-prepare() {
- cd $_pkgname
- patch -Np1 -i ../4.5.0.patch
-}
-
build() {
arch-meson $_pkgname build \
--auto-features=disabled \