summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimmKG2023-08-13 02:37:14 +0700
committerDimmKG2023-08-13 02:55:37 +0700
commit790290f235ee9949ca7130677d01d09525a9f066 (patch)
tree68bbef264853c727a10647f1b1758ddec7a0a598
parent830b8314dd1a40c3239863b8598e0b05ccdde46a (diff)
downloadaur-790290f235ee9949ca7130677d01d09525a9f066.tar.gz
Update to 1.0.0-SR0
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD64
-rw-r--r--changelog.txt134
4 files changed, 153 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5079772af01..cebe72a47c33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,26 @@
pkgbase = simulide
- pkgdesc = Real time electronic circuit simulator (supports PIC, AVR and Arduino microcontrollers)
- pkgver = 0.4.15_SR10
- pkgrel = 2
- url = https://www.simulide.com/
+ pkgdesc = Real time electronic circuit simulator (supports PIC, AVR and Arduino microcontrollers). Development version.
+ pkgver = 1.0.0_SR0
+ pkgrel = 1
+ url = https://launchpad.net/simulide
changelog = changelog.txt
arch = x86_64
license = GPL3
- makedepends = avr-libc
- makedepends = avr-gcc
+ makedepends = python-dulwich
+ makedepends = bzr
depends = qt5-base>=5.15.1
depends = qt5-multimedia
depends = qt5-serialport
depends = qt5-svg
depends = qt5-script
depends = qt5-tools
- depends = libelf>=0.181
- optdepends = gpsim: needed for PIC simulation
- optdepends = simavr: needed for AVR simulation
- source = https://launchpad.net/simulide/0.4.15/0.4.15-stable/+download/simulide_0.4.15-SR10_Sources.zip
+ provides = simulide
+ conflicts = simulide
+ source = simulide::bzr+https://code.launchpad.net/~arcachofo/simulide/1.0.0#revision=revno:1320
source = simulide.desktop
source = changelog.txt
- sha256sums = b108d804d4720daa5d3eb60e1d99b0cce57973cf8ba59546e7d389250f5eab8d
sha256sums = SKIP
+ sha256sums = a5b1f6b19d3fc2e93baa98beb000488a0e1f0fd93935cc7d86e8f0b345c11f23
sha256sums = SKIP
pkgname = simulide
diff --git a/.gitignore b/.gitignore
index 40e1cbfc9ab4..7c454592da5c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,3 +4,4 @@ src/
*.tar.xz
*.zst
*.zip
+simulide \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index fc5b4252ee05..3e78baaf67db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,31 @@
-# Maintainer: wereii <wereii@wereii.cz>
+# Maintainer: DimmKG <dirkg361@gmail.com>
+# Contributor: wereii <wereii@wereii.cz>
# Contributor: Base pkgbuild files provided by Damian Blanco <blanco.damian@gmail.com>
# Contributor: franciscod <demartino.francisco@gmail.com>
+# Based on: https://aur.archlinux.org/packages/simulide
pkgname=simulide
-pkgver=0.4.15_SR10
+pkgver=1.0.0_SR0
+_version_branch=1.0.0
_realver=${pkgver//_/-}
-pkgrel=2
-pkgdesc="Real time electronic circuit simulator (supports PIC, AVR and Arduino microcontrollers)"
+_rev=1320
+pkgrel=1
+pkgdesc="Real time electronic circuit simulator (supports PIC, AVR and Arduino microcontrollers). Development version."
arch=("x86_64")
-url="https://www.simulide.com/"
+url="https://launchpad.net/simulide"
+provides=('simulide')
+conflicts=('simulide')
license=("GPL3")
+changelog="changelog.txt"
source=(
- "https://launchpad.net/simulide/${pkgver//_*/}/${pkgver//_*/}-stable/+download/simulide_${_realver}_Sources.zip"
- "simulide.desktop"
- "changelog.txt")
-
-sha256sums=('b108d804d4720daa5d3eb60e1d99b0cce57973cf8ba59546e7d389250f5eab8d'
- SKIP
- SKIP)
+ "${pkgname}::bzr+https://code.launchpad.net/~arcachofo/simulide/${_version_branch}#revision=revno:${_rev}"
+ "simulide.desktop"
+ "changelog.txt")
+sha256sums=(
+ SKIP
+ 'a5b1f6b19d3fc2e93baa98beb000488a0e1f0fd93935cc7d86e8f0b345c11f23'
+ SKIP)
-changelog="changelog.txt"
depends=(
"qt5-base>=5.15.1"
"qt5-multimedia"
@@ -27,34 +33,34 @@ depends=(
"qt5-svg"
"qt5-script"
"qt5-tools"
- "libelf>=0.181"
-)
-
-optdepends=(
- "gpsim: needed for PIC simulation"
- "simavr: needed for AVR simulation"
)
makedepends=(
- "avr-libc"
- "avr-gcc"
+ "python-dulwich"
+ "bzr"
)
build() {
- cd "${srcdir}/simulide_${_realver}_Sources/build_XX"
+ cd "${srcdir}/${pkgname}/build_XX"
qmake
- make -j`nproc`
+ make
}
package() {
install -D -m644 simulide.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- #cp "${srcdir}/simulide_${_realver}_Sources/changelog.txt" "${srcdir}/.."
- cd "${srcdir}/simulide_${_realver}_Sources/build_XX/executables/SimulIDE_${_realver}"
- test -s "bin/${pkgname}" && test -x "bin/${pkgname}"
- test -d "share/${pkgname}"
+ cd "${srcdir}/${pkgname}/build_XX/executables/SimulIDE_${_realver}"
+ # binary
+ mkdir -p "${pkgdir}/usr/bin"
+ cp simulide "${pkgdir}/usr/bin/"
+ # data
+ mkdir -p "${pkgdir}/usr/share/simulide"
+ cp -r ./ "${pkgdir}/usr/share/simulide"
+ rm ${pkgdir}/usr/share/simulide/simulide
+
+ # icon
+ mkdir -p "${pkgdir}/usr/share/icons"
+ cp -r ${srcdir}/${pkgname}/resources/icons/* "${pkgdir}/usr/share/icons"
- mkdir -p "${pkgdir}/usr"
- cp -r ./* "${pkgdir}/usr" # usr/bin usr/share
}
diff --git a/changelog.txt b/changelog.txt
index 89822fb7a074..a3130f871370 100644
--- a/changelog.txt
+++ b/changelog.txt
@@ -1,30 +1,110 @@
-0.4.15-SR10
-
-Bug Fixes:
- - 74HC139 Error.
- - AVR ICR write error.
- - McuMonitor: RamTable not loading varList.
- - Logic Analizer: Time Pos. not initialized.
- - PIC16F887 ADC: Using Vref Pins doesn't work.
- - Ili9341: Error checking for address out of range.
- - Ili9341: Errors + command 0x36: Memory Access Control (no MV).
- - Oscilloscope not working if simulation already running.
- - RamTable not saving varlist.
- - Oscilloscope Ref Voltage error.
- - BJT: Error in setGain.
- - Ky023: Crash at delete.
- - KY023: Button not working.
- - Mosfet not cleanly deleted.
- - AVRs: CTC not working with external T0/T1.
- - Avr asm Debugger: wrong PC.
- - Atmega2560 Comparator not working.
- - Atmega2560: Missing PCINT1.0 and PCINT2.
+1.0.0-SR0
+
+First stable release
+
+1.0.0-RC2
+
+New features:
+- Editor: Set Compiler and Device in file (first line).
+- Editor: New Find/Replace Dialog.
+- 7Segment BCD: Show Pin labels.
+- Gates: Property "Randomize PD".
+- RamTable: New line after add register.
+- RamTable: Add register by <return>.
+- FlipFlops: Added property "Use Set/Reset Pins"
+- Auto-connect Pins to wires.
+- Component: Cut <Ctrl>+X Action.
+- Logic Outputs: Rising & falling slopes.
+- Variable Sources: current value Property.
+- Component Properties: accept e,+,-,*,/.
+- Show Revision number.
+- Logic Analizer: Added Channel names.
+- Logic Analizer: Set Time origin by Mouse Middle Button.
+- Mainwindow Title: Show Simulation state.
+
+New Components:
+-Subcircuits (Sergey Roenko).:
+ 7478,7471,7487,7494,7498,7499,74100,74101,74102,
+ 74103,74104,74105,74110,74111,74115,chip22
+ Displays 1 to bits, scc, sca.
+ Patern Generator.
+- Atmega8.
+- Atmega328pb (Kelnella).
+- Pic12F629.
+- Pic12F675.
+- Pic16F88x family.
+- Pic16F1826.
+- 555 (subcircuit version).
+- Fliflop T.
+- Serial Port.
+- Diac.
+- Triac.
+- SCR.
+- Socket.
+- Resistive TouchPad 4 wires (Kelnella).
+- DS1307 RTC.
+- Esp01 (TCP).
Changes:
- - Hungarian translation added.
- - Italian translation disabled.
- - New Subcircuits (Sergey Roenko):
- Pulse Generator.
- Real Button.
- Led Displays.
+- Unified App Settings dialog.
+- Don't open backup circuit after crash, ask if open or not.
+- Logic Analizer: Show only logic states.
+- KY040 to generic Relative Rotary Encoder.
+- Auto-Connect Pin to <Shift> + Move.
+
+1.0.0-RC1
+
+Circuit:
+ - Debug Panel.
+ - New Dialogs for Component properties.
+ - Animate Inputs/Outputs by type and state.
+ - Improved File load/save (faster, smaller files).
+ - More stable and faster Undo/Redo.
+ - Circuit: Ctrl+A selects all items.
+
+Components:
+ - Frequency property for I2C Devices.
+ - Increase Frequency meter resolution to 5 digits.
+ - SSD1306 I2C Address property.
+ - Load and Save to file for Function Component.
+ - I2C to Parallel: read implemented.
+ - I2C to Parallel: add internal pullups.
+ - Binary Couter: add Set Pin.
+ - Resizable Multiplexer and Demultiplexer
+ - Subcircuit: Name label editable.
+ - OpAmp: Power Pins labels.
+ - OpAmp: Switch Power Pins property.
+ - Meters: Switch Pins property.
+ - LM555 Refactored.
+ - Diode: new accurate model (Leds keep the simple fast model).
+ - Improved Non Linear convergence.
+ - Memtable: accept decimal, octal or hexadecimal values.
+ - MemTable: show ASCII by byte (2 for 16 bits and so on).
+ - Load hex working for all Memories.
+ - Oscope: Added "Filter" Box.
+ - Wavegen: standard Mid volt. and Semi amplitude.
+ - DC Motor: Red & Black connectors (more visible).
+ - Seven Segment: add Pin labels.
+ - Led RGB.
+ - DHT22/11 Temperature+Humidity sensor.
+
+MCU:
+ - New MCU Simulator.
+ - Several MCUs in Circuit.
+ - 8051 MCU.
+ - Uart Pins working.
+ - MCU crash Warning message and animation.
+ - Arduino Shields (experimental).
+ - McuMonitor: Change font size and color & PC-STATUS position.
+ - McuMonitor: Unify "Variables" & "RAM" tabs
+ - McuMonitor: PC & flash by PGM word size or byte.
+ - McuMonitor: Added "Jump to address" option.
+
+Editor/Compiler/Debugger:
+ - Editable and custom compilers.
+ - New menu button & dialogs for Editor and Compilers settings.
+ - "Clear All Breakpoints" action added.
+ - Added Compilers/Debuggers: SDCC, avr-gcc, avr-gcc Makefile, avr-gcc asm, gavrasm.
+ - 8051 asm highlighting.
+ - Hex file highlighting.