summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwicast2016-04-24 20:49:43 +0800
committerwicast2016-04-24 20:49:43 +0800
commit791e05486b4d876d5e4b4e1a9b28a194a7432ef7 (patch)
tree42c227c1c1fc348325209a699d726cd1e45c166f
downloadaur-791e05486b4d876d5e4b4e1a9b28a194a7432ef7.tar.gz
Init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7288c288106a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Apr 24 12:49:30 UTC 2016
+pkgbase = python-lda
+ pkgdesc = Topic modeling with latent Dirichlet allocation
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/ariddell/lda/
+ arch = i686
+ arch = x86_64
+ license = MPLv2
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pbr
+ source = http://pypi.python.org/packages/source/l/lda/lda-1.0.3.tar.gz
+ md5sums = 17efa4f18d1aa5b08997db709d7ab068
+
+pkgname = python-lda
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..996f748ed4e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer wicastC <wicastchen at hotmail dot com>
+
+pkgname=python-lda
+_name=lda
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Topic modeling with latent Dirichlet allocation"
+arch=("i686" "x86_64")
+url="https://github.com/ariddell/lda/"
+license=(MPLv2)
+depends=("python" "python-pbr")
+makedepends=("python-setuptools")
+source=("http://pypi.python.org/packages/source/l/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=("17efa4f18d1aa5b08997db709d7ab068")
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ msg "Install..."
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" || return 1
+}