summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2014-04-25 00:01:20 +0000
committerKyle Keen2014-04-25 00:01:20 +0000
commit793bfb8156ddec2e0baeb19d043fdf2fec8683c2 (patch)
treebb397e0b940837ee266336685c45f24a88249a74
parent737cac25d2cdc4a36eaed6bb7ab831f9b7966ec6 (diff)
downloadaur-793bfb8156ddec2e0baeb19d043fdf2fec8683c2.tar.gz
updated on Fri Apr 25 00:01:20 UTC 2014
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7165c259b87..df8b0b1ed445 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = android-apktool-git
pkgdesc = a tool for reengineering Android apk files
- pkgver = v1.5.2.r164.g4b180bd
+ pkgver = 2.0.0.Beta9.g251a6bb
pkgrel = 1
url = https://code.google.com/p/android-apktool/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index b52874e373b9..d91a9167fba5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=android-apktool-git
_gitname=Apktool
_gitbranch=wip-2.0
_gitauthor=iBotPeaches
-pkgver=v1.5.2.r164.g4b180bd
+pkgver=2.0.0.Beta9.g251a6bb
pkgrel=1
pkgdesc="a tool for reengineering Android apk files"
arch=('i686' 'x86_64')
@@ -19,7 +19,8 @@ sha512sums=('SKIP')
pkgver() {
cd "$srcdir/$_gitname"
- git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+ # This is a heck of a line, but I found it way the only way of getting the version number properly
+ printf "$(grep "def apktoolversion_major" build.gradle | sed "s/.*'\(.*\)'.*/\1/").$(grep "def apktoolversion_minor" build.gradle | sed "s/.*'\(.*\)'.*/\1/").$(git describe | sed -n -e 's/^.*-//p')"
}
build() {