summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2023-06-09 17:10:48 +1000
committerVictor Tran2023-06-09 17:10:48 +1000
commit7948abbbd85d5e3cd71699e434d2169921e95983 (patch)
tree5f19362a0069a99973afb568e7522b65694ed154
parentfc1dfcde67025ca03c8a84b1790bc5fc450ef668 (diff)
downloadaur-7948abbbd85d5e3cd71699e434d2169921e95983.tar.gz
Update to 2.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 20 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a97ac5623e49..423f16f21eb7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = contemporary-widgets
pkgdesc = Contemporary Widget Theme
- pkgver = 1.7
+ pkgver = 2.0
pkgrel = 0
- url = https://github.com/vicr123/contemporary-theme
+ url = https://github.com/theCheeseboard/contemporary-theme
arch = x86_64
+ arch = aarch64
license = GPL3
makedepends = git
- depends = qt5-base
- depends = the-libs
- source = https://github.com/vicr123/contemporary-theme/archive/v1.7.tar.gz
- sha256sums = b1ebd8832e2f3d3335c9d48db68b0dda2594f317aadcd6a24e09ab4e8ec1c3e4
+ makedepends = qt6-tools
+ makedepends = cmake
+ makedepends = clang
+ depends = libcontemporary
+ source = contemporary-widgets-2.0::https://github.com/theCheeseboard/contemporary-theme/archive/v2.0.tar.gz
+ sha256sums = 4be56bfe3279503cccc6bba782225e0924c884899e316ef52c1e1e057b0639ec
pkgname = contemporary-widgets
-
diff --git a/PKGBUILD b/PKGBUILD
index 5eb12280e7cd..d02be998b76c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=contemporary-widgets
-pkgver=1.7
+pkgver=2.0
pkgrel=0
pkgdesc="Contemporary Widget Theme"
-arch=("x86_64")
-url="https://github.com/vicr123/contemporary-theme"
+arch=("x86_64" "aarch64")
+url="https://github.com/theCheeseboard/contemporary-theme"
license=('GPL3')
-depends=('qt5-base' 'the-libs')
-makedepends=('git')
-source=('https://github.com/vicr123/contemporary-theme/archive/v1.7.tar.gz')
-sha256sums=('b1ebd8832e2f3d3335c9d48db68b0dda2594f317aadcd6a24e09ab4e8ec1c3e4')
+depends=('libcontemporary')
+makedepends=('git' 'qt6-tools' 'cmake' 'clang')
+source=("$pkgname-$pkgver"::"https://github.com/theCheeseboard/contemporary-theme/archive/v$pkgver.tar.gz")
+sha256sums=('4be56bfe3279503cccc6bba782225e0924c884899e316ef52c1e1e057b0639ec')
build() {
- cd "contemporary-theme-$pkgver"
- qmake
- make
+ cmake -B build -S "contemporary-theme-$pkgver" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
}
package() {
- cd "contemporary-theme-$pkgver"
- make install INSTALL_ROOT=$pkgdir
+ DESTDIR="$pkgdir" cmake --install "build"
}