summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLouis Rannou2022-02-23 23:28:22 +0100
committerLouis Rannou2022-02-23 23:34:53 +0100
commit7966bde7056f971ba6927e89c373d1cd8a1a6120 (patch)
tree8405ded905a64422dae4b6f8e150cd61b0cee6ff
parent81462dcf373d329032126d548d763432d7de0e03 (diff)
downloadaur-7966bde7056f971ba6927e89c373d1cd8a1a6120.tar.gz
Recreate package at version 1.0.4
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD36
-rw-r--r--emacs-rust-mode.install19
3 files changed, 43 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a56ae6a534e..db187ca85b5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = emacs-rust-mode
pkgdesc = A major Emacs mode for editing Rust source code
- pkgver = r427
- pkgrel = 1
+ pkgver = 1.0.4
+ pkgrel = 2
url = https://github.com/rust-lang/rust-mode
+ install = emacs-rust-mode.install
arch = any
- license = MIT
- makedepends = git
+ license = Apache
depends = emacs
- source = emacs-rust-mode::git://github.com/rust-lang/rust-mode.git
- sha256sums = SKIP
+ source = https://github.com/rust-lang/rust-mode/archive/refs/tags/1.0.4.tar.gz
+ sha256sums = e8eca03382d01a73bc00b29292d99ee2597023e0e97273e1b1969fb44f140f2e
pkgname = emacs-rust-mode
-
diff --git a/PKGBUILD b/PKGBUILD
index 458360a7abf2..a6e09bc1ce51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
-# Maintainer: Jon Eyolfson <jon@eyl.io>
+# Maintainer: louson - Louis Rannou <louis dot rannou at gresille dot org>
+# Contributor: Jon Eyolfson <jon@eyl.io>
pkgname=emacs-rust-mode
-pkgver=r427
-pkgrel=1
+pkgver=1.0.4
+pkgrel=2
pkgdesc="A major Emacs mode for editing Rust source code"
arch=('any')
url="https://github.com/rust-lang/rust-mode"
+license=('Apache')
depends=('emacs')
-makedepends=('git')
-license=('MIT')
-source=("$pkgname"::'git://github.com/rust-lang/rust-mode.git')
-sha256sums=(SKIP)
-pkgver() {
- cd "$srcdir/$pkgname"
- printf "r%s" "$(git rev-list --count HEAD)"
-}
+install="${pkgname}.install"
+source=("https://github.com/rust-lang/rust-mode/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('e8eca03382d01a73bc00b29292d99ee2597023e0e97273e1b1969fb44f140f2e')
-build() {
- cd "$srcdir/$pkgname"
- emacs -batch -f batch-byte-compile rust-mode.el
+package() {
+ cd "$srcdir/rust-mode-${pkgver}"
+ for file in rust-mode.el rust-utils.el \
+ rust-cargo.el rust-compile.el rust-playpen.el rust-rustfmt.el
+ do
+ install -Dm644 "${file}" "${pkgdir}"/usr/share/emacs/site-lisp/rust-mode/"${file}"
+ done
}
-package() {
- install -d $pkgdir/usr/share/emacs/site-lisp
- cd "$srcdir/$pkgname"
- cp rust-mode.{el,elc} $pkgdir/usr/share/emacs/site-lisp
+check () {
+ cd "$srcdir/rust-mode-${pkgver}"
+ make test
}
diff --git a/emacs-rust-mode.install b/emacs-rust-mode.install
new file mode 100644
index 000000000000..2db65c15f7a5
--- /dev/null
+++ b/emacs-rust-mode.install
@@ -0,0 +1,19 @@
+post_install() {
+ cat <<EOF
+==> Add this code to your Emacs init to use rust-mode:
+
+(autoload 'rust-mode "rust-mode.el"
+ "Major mode for editing Rust files" nil t)
+(add-to-list 'auto-mode-alist '("\\.rs\\'" . rust-mode))
+
+==> Add this code to ignore optional libraries
+(defvar rust-load-optional-libraries nil
+ "Whether loading `rust-mode' also loads optional libraries.")
+
+EOF
+}
+
+
+post_upgrade() {
+ post_install $1
+}