summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2017-01-25 21:59:34 -0500
committerJames An2017-01-25 21:59:34 -0500
commit79a13a6f1d39bbf7f2a1e092ee7c38da5a230618 (patch)
tree7c8d8cc8122023257a0a79ea430d6a6c57a9e4a2
downloadaur-79a13a6f1d39bbf7f2a1e092ee7c38da5a230618.tar.gz
Initial commit with working PKGBUILD.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD30
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..80119d6b899a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = php-codesniffer-drupalsecure
+ pkgdesc = Secure coding validation tool for Drupal built on PHP_CodeSniffer and modeled after work on DrupalCS in the Coder module
+ pkgver = r3.782f704
+ pkgrel = 1
+ url = https://www.drupal.org/sandbox/coltrane/1921926
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = php-codesniffer
+ source = secure_cs::git+https://git.drupal.org/sandbox/coltrane/1921926.git
+ md5sums = SKIP
+
+pkgname = php-codesniffer-drupalsecure
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..785639149fd4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+### https://raw.github.com/github/gitignore/a41bfbea916d6d2e010d0d232895f9c65bd0d502/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# Ignore package source folders
+*/*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4232dbc8e358
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: James An <james@jamesan.ca>
+
+pkgname=php-codesniffer-drupalsecure
+_pkgname=secure_cs
+pkgver=r3.782f704
+pkgrel=1
+pkgdesc="Secure coding validation tool for Drupal built on PHP_CodeSniffer and modeled after work on DrupalCS in the Coder module"
+arch=("any")
+url="https://www.drupal.org/sandbox/coltrane/1921926"
+license=("GPL")
+depends=("php-codesniffer")
+makedepends=("git")
+source=("$_pkgname"::"git+https://git.drupal.org/sandbox/coltrane/1921926.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ (
+ set -o pipefail
+ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ install -d "$pkgdir/usr/share/pear/PHP/CodeSniffer/Standards"
+ cp -dr --no-preserve=ownership "$_pkgname/DrupalSecure" "$pkgdir/usr/share/pear/PHP/CodeSniffer/Standards"
+ install -d "$pkgdir$(dirname "$(realpath "$(which drush)")")/commands"
+ cp -dr --no-preserve=ownership "$_pkgname/$_pkgname.drush.inc" "$pkgdir$(dirname "$(realpath "$(which drush)")")/commands"
+}