summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanManN2018-12-21 12:07:40 -0500
committerDanManN2018-12-21 12:07:40 -0500
commit79abf72b54c414e6bec8235b16edf256b78bf1bc (patch)
tree02947387ef47dbe9a7b39dabd9e43b7a7b1703f8
parent0895334a29dc6d4856b5022cdb72f73b345c5188 (diff)
downloadaur-79abf72b54c414e6bec8235b16edf256b78bf1bc.tar.gz
version based on releases
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d1b63b51130..ef0366dcfa66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-wasabi-git
pkgdesc = A lightweight console printing and formatting toolkit
- pkgver = 0.0.10.r72.0363236
- pkgrel = 1
+ pkgver = 0.0.15.r96.4ff962b
+ pkgrel = 2
url = https://github.com/ines/wasabi
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 2a69c1a2003c..362e647e47b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Python package author: Ines Montani <ines@explosion.ai>
pkgname=python-wasabi-git
_origpkgname=wasabi
-pkgver=0.0.10.r72.0363236
-pkgrel=1
+pkgver=0.0.15.r96.4ff962b
+pkgrel=2
pkgdesc="A lightweight console printing and formatting toolkit"
arch=("x86_64")
url="https://github.com/ines/wasabi"
@@ -15,6 +15,11 @@ conflicts=('python-wasabi')
source=("git+https://github.com/ines/$_origpkgname.git")
md5sums=('SKIP')
+prepare() {
+ cd "$_origpkgname"
+ git checkout $(curl https://api.github.com/repos/ines/$_origpkgname/releases/ | grep tag_name | cut -d '"' -f4 | head -n 1)
+}
+
pkgver() {
cd "$_origpkgname"
printf "%s.r%s.%s" "$(cat wasabi/about.py | grep -i version | grep -v '#' | cut -d '"' -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"