summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-09 11:44:32 +0000
committerGrey Christoforo2019-02-09 11:44:32 +0000
commit79ad5f2a5f5f17c896746f18a8460b7464865dd7 (patch)
treec9c5f449da67aa5c92566acd92e5988249c74b64
parent171f699c543b5410fa662bda840afa98f74ca433 (diff)
downloadaur-79ad5f2a5f5f17c896746f18a8460b7464865dd7.tar.gz
version bump
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 19 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0eed00aa7710..a43946e3d0e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,14 +2,12 @@ pkgbase = r-munsell
pkgdesc = Utilities for Using Munsell Colours
pkgver = 0.5.0
pkgrel = 1
- url = https://cran.r-project.org/package=munsell
- arch = any
- license = MIT
+ url = http://cran.r-project.org/web/packages/munsell/index.html
+ arch = x86_64
+ license = GPL3
depends = r
depends = r-colorspace
- optdepends = r-ggplot2
- optdepends = r-testthat
- source = https://cran.r-project.org/src/contrib/munsell_0.5.0.tar.gz
+ source = http://cran.r-project.org/src/contrib/munsell_0.5.0.tar.gz
md5sums = b287f380a958399cfa12f665232e7f34
pkgname = r-munsell
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 2c3a718e7e49..9e9260b1d070 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,19 @@
-# Maintainer: Alex Branham <branham@utexas.edu>
-_cranname=munsell
-_cranver=0.5.0
-_pkgtar=${_cranname}_${_cranver}.tar.gz
+# Contributor: Grey Christoforo <first name at last name dot net>
pkgname=r-munsell
-pkgver=${_cranver//[:-]/.}
+_cran_name=munsell
+pkgver=0.5.0
pkgrel=1
pkgdesc="Utilities for Using Munsell Colours"
-arch=('any')
-url="https://cran.r-project.org/package=${_cranname}"
-license=('MIT')
+arch=('x86_64')
+url="http://cran.r-project.org/web/packages/${_cran_name}/index.html"
+license=('GPL3')
depends=('r' 'r-colorspace')
-
-optdepends=('r-ggplot2' 'r-testthat')
-
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+source=("http://cran.r-project.org/src/contrib/${_cran_name}_${pkgver}.tar.gz")
md5sums=('b287f380a958399cfa12f665232e7f34')
-build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
-}
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
-}
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+}