summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormatheuz12102021-08-30 21:47:26 -0300
committermatheuz12102021-08-30 21:47:26 -0300
commit79decbee84dd149a6da4081173623a67d41b9bd6 (patch)
tree299c13f2916e581eab2ad07c720d22cba488668b
downloadaur-79decbee84dd149a6da4081173623a67d41b9bd6.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8dc7b357f0ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wsid
+ pkgdesc = web show image directory
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/matheuz1210/wsid
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python>=3.9
+ optdepends = python-pyqt5: for gui
+ source = wsid::git+https://github.com/matheuz1210/wsid#tag=0.1
+ b2sums = SKIP
+
+pkgname = wsid
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3701e3cd922
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: matheuz1210 <matheuz1210 at gmail dot com>
+
+pkgname=wsid
+pkgver=0.1
+pkgrel=1
+pkgdesc='web show image directory'
+arch=(any)
+url='https://github.com/matheuz1210/wsid'
+license=(GPL)
+depends=(
+ 'python>=3.9' )
+makedepends=(
+ git )
+optdepends=(
+ 'python-pyqt5: for gui' )
+source=(
+ "${pkgname%-git}::git+${url}#tag=${pkgver}" )
+b2sums=(SKIP)
+
+package(){
+ cd "${srcdir}/${pkgname%-git}"
+ install -Dm755 wsid -t "${pkgdir}/usr/bin"
+}