summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2023-09-08 12:30:58 +0200
committerChristopher Arndt2023-09-08 12:30:58 +0200
commit79e2444188668af9fc4abf75fc8e8cf372594baa (patch)
tree9b1b63a654f4d0ad2c8dac20133592e434563b8a
parentba5031a35bee8aeeecdd3ea544630e202ba9014f (diff)
downloadaur-79e2444188668af9fc4abf75fc8e8cf372594baa.tar.gz
Various PKGBUILD fixes & improvements
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD72
-rw-r--r--geonkick-vst3sdk-include-stdint.patch12
4 files changed, 79 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f1e57e5e242..c33d0aa1f715 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,42 @@
pkgbase = geonkick-git
pkgdesc = A free software percussion synthesizer (git version)
- pkgver = 2.9.0.r1159.67b2102a
+ pkgver = 2.10.0.r1198.7d35d04f
pkgrel = 1
- url = https://gitlab.com/iurie-sw/geonkick
+ url = https://gitlab.com/geonkick/geonkick
arch = x86_64
- groups = pro-audio
groups = lv2-plugins
+ groups = pro-audio
+ groups = vst3-plugins
license = GPL3
+ checkdepends = lv2lint
makedepends = cmake
+ makedepends = git
makedepends = jack
makedepends = lv2
makedepends = rapidjson
makedepends = sord
+ depends = gcc-libs
+ depends = glibc
depends = cairo
depends = hicolor-icon-theme
+ depends = libx11
depends = libsndfile
optdepends = jack: for stand-alone application
+ optdepends = lv2-host: for loading the LV2 plugin
+ optdepends = vst3-host: for loading the VST3 plugin
provides = geonkick
+ provides = geonkick-common
+ provides = geonkick-lv2
+ provides = geonkick-standalone
+ provides = geonkick-vst3
conflicts = geonkick
- source = geonkick::git+https://gitlab.com/iurie-sw/geonkick.git
+ conflicts = geonkick-common
+ conflicts = geonkick-lv2
+ conflicts = geonkick-standalone
+ conflicts = geonkick-vst3
+ source = geonkick::git+https://gitlab.com/geonkick/geonkick.git
+ source = geonkick-vst3sdk-include-stdint.patch
sha512sums = SKIP
+ sha512sums = 2c0463f3eb27fc714a5b50b49ba9a83aab92dcd5ed713566d5149f8ca18866bee704f6064505389ddf06b21e250b9acfcd93df0e5c05f51fd03ee8f0af8b320b
pkgname = geonkick-git
diff --git a/.gitignore b/.gitignore
index 273ad335ab38..610ee4c832a2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,4 @@
geonkick/
pkg/
src/
-geonkick-git-*.pkg.tar.xz
-geonkick-git-*.pkg.tar.zst
-geonkick-git-*.tar.zst
-.AURINFO
+geonkick-git-*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index f08135d86e7a..0dfa4f9e5dd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,66 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot -de>
+_plugin_uri='http://geontime.com/geonkick'
_pkgname=geonkick
pkgname="${_pkgname}-git"
-pkgver=2.9.0.r1159.67b2102a
+pkgver=2.10.0.r1198.7d35d04f
pkgrel=1
-pkgdesc="A free software percussion synthesizer (git version)"
-arch=('x86_64')
-url="https://gitlab.com/iurie-sw/geonkick"
-license=('GPL3')
-groups=('pro-audio' 'lv2-plugins')
-depends=('cairo' 'hicolor-icon-theme' 'libsndfile')
-makedepends=('cmake' 'jack' 'lv2' 'rapidjson' 'sord')
-optdepends=('jack: for stand-alone application')
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-source=("${_pkgname}::git+https://gitlab.com/iurie-sw/geonkick.git")
-sha512sums=('SKIP')
-
+pkgdesc='A free software percussion synthesizer (git version)'
+arch=(x86_64)
+url='https://gitlab.com/geonkick/geonkick'
+license=(GPL3)
+groups=(lv2-plugins pro-audio vst3-plugins)
+depends=(gcc-libs glibc cairo hicolor-icon-theme libx11 libsndfile)
+makedepends=(cmake git jack lv2 rapidjson sord)
+checkdepends=(lv2lint)
+optdepends=(
+ 'jack: for stand-alone application'
+ 'lv2-host: for loading the LV2 plugin'
+ 'vst3-host: for loading the VST3 plugin'
+)
+provides=($_pkgname $_pkgname-common $_pkgname-lv2 $_pkgname-standalone $_pkgname-vst3)
+conflicts=($_pkgname $_pkgname-common $_pkgname-lv2 $_pkgname-standalone $_pkgname-vst3)
+source=("$_pkgname::git+https://gitlab.com/geonkick/geonkick.git"
+ 'geonkick-vst3sdk-include-stdint.patch')
+sha512sums=('SKIP'
+ '2c0463f3eb27fc714a5b50b49ba9a83aab92dcd5ed713566d5149f8ca18866bee704f6064505389ddf06b21e250b9acfcd93df0e5c05f51fd03ee8f0af8b320b')
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
local ver="$(grep 'geonkick VERSION' CMakeLists.txt | cut -d ' ' -f 3 | tr -d ')')"
echo "$ver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd $_pkgname
+ patch -p1 -N -r - -i "$srcdir"/geonkick-vst3sdk-include-stdint.patch
+}
+
build() {
- cd "${srcdir}/${_pkgname}"
- mkdir -p build
- cd build
cmake \
+ -B $_pkgname-build \
+ -S $_pkgname \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DGKICK_VST3=ON \
- ..
- make
+ -W no-dev
+ cmake --build $_pkgname-build
}
+check() {
+ cp -av $_pkgname-build/plugin/lv2/*.so $_pkgname/plugin/lv2/$_pkgname.lv2/
+ lv2lint -Mpack -I $_pkgname/plugin/lv2/$_pkgname.lv2/ "$_plugin_uri"
+ rm $_pkgname/plugin/lv2/$_pkgname.lv2/*.so
+}
+
+
package() {
- cd "${srcdir}/${_pkgname}"
- (
- cd build
- make DESTDIR="$pkgdir/" install
- )
+ DESTDIR="$pkgdir" cmake --install $_pkgname-build
+ cd $_pkgname
# desktop file
- install -vDm 644 "data/${_pkgname}.desktop" \
- -t "${pkgdir}/usr/share/applications"
+ install -vDm 644 data/$_pkgname.desktop \
+ -t "$pkgdir"/usr/share/applications
# documentation
- install -vDm 644 README.md NEWS.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -vDm 644 README.md NEWS.md \
+ -t "$pkgdir"/usr/share/doc/$pkgname
}
diff --git a/geonkick-vst3sdk-include-stdint.patch b/geonkick-vst3sdk-include-stdint.patch
new file mode 100644
index 000000000000..93459cff3fd3
--- /dev/null
+++ b/geonkick-vst3sdk-include-stdint.patch
@@ -0,0 +1,12 @@
+diff --git a/3rdparty/vst3_sdk/public.sdk/source/vst/utility/stringconvert.h b/3rdparty/vst3_sdk/public.sdk/source/vst/utility/stringconvert.h
+index ff910aaa..28c3681d 100644
+--- a/3rdparty/vst3_sdk/public.sdk/source/vst/utility/stringconvert.h
++++ b/3rdparty/vst3_sdk/public.sdk/source/vst/utility/stringconvert.h
+@@ -37,6 +37,7 @@
+ #pragma once
+
+ #include "pluginterfaces/vst/vsttypes.h"
++#include <cstdint>
+ #include <string>
+
+ //------------------------------------------------------------------------